Sketchfab Forum

Removing Tutorial


(JERSIED) #1

I've had some custom work done for Sketchfab on my website (www.jersied.com) and I've run into an issue at the finish line. My developer can't disable the tutorial that shows up for first time users of sketchfab.

I've covered the model view with a DIV so that users can't interact with the model directly and added buttons that cycle through the annotation views. This accomplishes two things: 1) on mobile it's easier to navigate the site as without the DIV covering the model a user spins the model around by accident when trying to scroll through my site 2) it's much easier for people to view/interact with the model on my site.

Unfortunately, after all this work, I'm left with a terrible first time user experience on my site because the viewer is showing the tutorial teaching people to interact with the model but my site doesn't allow it.

Seems it should be able to comment out this code... Can anyone on the development team help me out?

Side question: Where should I got to request features?


#2

Hi,

It's not possible to remove this yet, but I'll add your '+1' to this feature request.

You can use the ?scrollwheel=0 parameter to disable zooming, but it will not work for mobile touch events.

Sorry for the inconvenience.

James


(JERSIED) #4

Can I bride someone with a nice bottle of wine to make this happen sooner rather than later? :slight_smile:


(JERSIED) #5

Note: 90% of the traffic on my site is mobile, so the experience really needs to be optimized for the mobile platform. The scrolling issue was a big one for me.


(JERSIED) #6

Has this been changed? I'm thinking about switching back to Sketchfab from Clara but given this awkward nuisance I may not want to...


(Mauricesvay) #7

Premium accounts can disable it with the embed parameter ui_hint:


(JERSIED) #8

THIS IS FANTASTIC, THANK YOU SKETCHFAB!

Apparently I need to write a full sentence in order for my post to be submitted... just wanted to say thanks!