Render on iPad Pro (only) wrong

Hi

Render on Ipad Pro (11 inch) is wrong.

Render looks correct on windows PC, iphone 6s and iphone 8.

I have updated all ios to latest 13.1.1 for both iphones and ipad.

Attached snapshots for each.

Can you please let me know if the issue needs to be resolved by vieweres with iPad Pros or indeed maybe a bug with Sketchfab?

Thank you, Sergio

Hi there,

We believe this is a bug introduced by Apple in Safari + iOS 13.x, potentially related to this WebKit bug: https://bugs.webkit.org/show_bug.cgi?id=200807

We’re still investigating, but if that’s the case, it should be fixed in an upcoming version.

Thanks James, please keep us in the loop. Interesting to note this does not happen on iPhone 6s, 8 both on same iOS update 13.1.1.

Cheers, Sergio

Yep, we think it’s something very specific to particular iPad GPUs + Safari + iOS 13.x.

It should be ok in Chrome, for example.

1 Like

A post was split to a new topic: iPad fullscreen zoom does not work + crash

We found the cause of the issue, and we have a fix on the way. Until then:

This is actually an option Apple has turned on by default, they are falsely claiming in the user agent that the user is running MacOS 10.15 and an Intel chip. You can turn this option off under Settings - Safari - Request Desktop Website on - All Websites

It’s not clear why this change was made to be on by default as it’s not accurate.

To switch from desktop to mobile mode in your iPad:

  1. Go to the Settings > Safari > Request Desktop Website.
  2. Under the Request Desktop Website On section, click All Websites to turn off

After this settings update, you will get the user agent as iPad.

1 Like

@james & Star team , thanks a bunch for finding the issue and proposed interim solution ! It’s also true asking clients to be changing their settings is quite challenging, when the fix comes through it’ll really help us :slight_smile:

Thanks again for your focus on this issue, cheer, Sergio

2 Likes

The “real” fix should be live now :slight_smile:

confirmed @james works great now :slight_smile: