Scene with multiple models only displays one model?


(Rory Baxter) #1

I have tried different of ways to upload a few of models that make up one scene. I have selected and uploaded them in the Upload dialogue window or combined them in a ZIP but the result is that only one of the models displays in the scene.

Is this normal? Should all the models be combined into one scene file? Even if different parts have animation?


(Stephomi) #2

This topic should help you Upload more than one object


(Rory Baxter) #3

Thanks stephomi.

Interesting workaround for OBJ files.

My current workflow is FBX that have their own animations.


#4

Is there a main FBX file with the mesh + separate FBX files for each animation? We will support this very soon.


(Rory Baxter) #5

I have a scene with a number of objects, some of which are animated.

Are you saying that (in the future) I could export the whole scene as an FBX, then export the animations separately, or, I could export FBX meshes with animation separately?


#6

Sorry I’m a bit confused now. What software are you using? Can you send us sample files?


(Rory Baxter) #7

Sorry, I’m new to this and have been learning how to export FBX files to Sketchfab (and Unity).

I’m using Blender so I am baking the animations (or ‘Actions’) for each animated mesh to keyframes.

I am then selecting all the static and animated mesh elements and exporting them as one FBX file to Sketchfab.

I thought that the support you mentioned coming soon might mean you could export any animation as a separate file, which I might have misunderstood.

I won’t send you my blender file, but here is a Blender preview render - the seaweed, grass, chest lid and bubbles are animated.


#8

Have you tried uploading the .blend file directly or using the built-in uploader?

https://sketchfab.com/exporters/blender


(Rory Baxter) #9

I have tried this before and just tried it again - I LOVE how the animation plays without having to bake it down to keyframes in Blender.

But, Auto Smooth settings for each object are lost which makes them display smoothed all over.

I have tried selecting sharp edges / marking sharp then turning off Auto Smooth but this data is also lost in the export.

Scene link.

Screen grabs below from two scenes I have uploaded: top is using Sketchfab Exporter, bottom is exporting to FBX.


(Rory Baxter) #10

I found a tip on the Babylon.js resources pages (link, halfway down page under ‘Meshes’) that suggested selecting sharp edges and applying an Edge Split modifier to those edges. This has held the shading I wanted without any gaps in the geometry.

Apart from this tweak, the Blender Sketchfab exporter made it so quick and easy to upload the whole scene AND animation in one go without having to bake any of the animation to keyframes.

Scene link.


#11

Nice, glad you got it working. I was going to recommend the same tweak: