Shaky animation problem FBX

fbx
maya
animation

(Andrewthomashuang) #1

Having issues with animation jitter/shake on character skeleton when importing FBXs exported from Maya 2016

I've tried the following with no luck:
* re-exporting FBX 2014/15
* scaling the model down
* baking keys at 0.2 frames instead of by frame 1.0
* setting scene scale unit 1.0

Another note is that I previously uploaded this same FBX 6 months ago over the summer and the interpolation worked totally fine. Re-uploading the same FBX file now 6 months later and having this animation shake/jitter problem.

Would greatly appreciate any tips or suggestiona.

Thank you!


(Hansolocambo) #2

I have the same issue with my Substance Designer Tests at this adress :

I followed the insctructions given here

and also tried many other combinations of my own while exporting the FBX, but result is always shaky. I get a clean animation though if I import the same file in Blender or Maya. And my grandfather who's got Parkinson's disease told me they were not shaky at all. So I don't know what to do anymore :confounded:

Any tip, as Andrew Thomas Huang said : would be greatly appreciated :slight_smile:
Cheers. HanSoloCambo.

P.S : andrewthomashuang, I went to see your profile : 0 Like, 0 collection, 0 model ... at all ! How can Sketchfab team investigate the issue further if the shaky file you're talking about is not even uploaded on your profile ?


(Andrewthomashuang) #3

Thanks HanSoloCambo glad i'm not the only one. (The shaders/textures for your substance designer tests look beautiful btw)

I've had to keep my models private bc this is for a commercial client but I did try another (crappy looking) test here on a totally different character rig: https://sketchfab.com/models/44922910cd384d97bc47ddc81480e152

You'll notice that her right leg shakes still. It's not nearly as bad as rig I'm trying to fix but at least i know that this problem isn't specific to the particular character rig I'm working on.

I've been trying to narrow down more variables. So far I've tried the following:

  • exporting different FBX settings (i've tried exporting to FBX 2014/15, checking constraints, baking keys on export, changing the world units - nothing works so far)

  • changing out the rig itself - I've switched out the animation with different character rigs and vice versa and still get the same jitter so i know it is not related to one specific rig

  • scale of animation - i've changed the rig scale by 10x smaller and larger and no luck

  • baking keys - tried baking keys by step 0.2 , 1.0 and 5.0 - still get jitter in every case

  • the skinning - i've tried unbinding the skeleton from the mesh and rebinding - still get jitter

Now I am still experimenting with the following:

  • the joint orientation - need to check orientation of individual joints to see if there might be issues with gimbal lock

  • version of Maya i'm exporting from - currently baking & exporting from Maya 2016 SP6 have not yet tried exporting from a diff version

  • centering the model - i doubt this will work but worth a try

Will update you if i have any luck.

Cheers
A


(Hansolocambo) #4

Thanks for sharing those attempts at fighting the issue. As far as I'm concerned, it's no complex rigging. Just a linear rotation. Simpler than that you can't do. I tried my FBX in Max 2013, Max 2017, Blender, Maya 2017 and Unity : It works fine everywhere. Just shaky in Sketchfab. Oh well...
I don't think it's our job to fix the issue or that the issue is really because of the way we exported the fxb. No big deal :slight_smile: But sure, if you find the reason why, I'll be glad to hear it :slight_smile:
I prefer to spend time on a more important issue : finding a job. So I need to learn Substance Designer. After 5 days of tutorials, my head's going to explode. It's quiet complex this thing. But damn exciting. Then I have to learn Substance Painter. I've been using only 3D-Coat but I really need to keep it for Unwrapping and retopology only. Texture tools are excellent but not enough to find a good job. And that's what I really need :slight_smile:
Cheers mate. Good luck with your investigations.
P.S I checked your link and the page gave me a 404.


(Mrchlblng) #5

@andrewthomashuang @hansolocambo we just shipped a fix dealing with some animation compression issues (that caused some shaking artifacts). You may find more technical details in the post: https://forum.sketchfab.com/t/animation-problem-blender/12788/11.

@andrewthomashuang I'm however surprised wen you say that a model was processed fine 6 months ago and now vibrates as our animation compression pipeline has not changed much lately. Could it be that you baked the animation in your last attempt? Could you provide URL or samples (to support@sketchfab.com if those are confidential)?


(Andrewthomashuang) #6

@mrchlblng Thank you so much for your help with the new fixes!

I tried two new uploads today and sent the links to James at support@sketchfab

It is better but you'll find in the links there are still animation glitches that seem to happen repeatedly in the same place if you watch the character's head on both tests.

I did bake the animation the same way in both the fbx from 6 months ago and the latest.

Your new fixes have definitely helped make the animation much smoother though. Do let me know if there's anything you can do about the final glitches - it's nearly there!

Many thanks again!
A


(Mrchlblng) #7

@andrewthomashuang sorry for this late reply. We've fixed some more issues in the animation compression; we detect too large errors more accurately and disable compression in such a case so it should no longer glitch!


(Soren Falske) #8

Hey there- it seems I have the same problem in my model; I've uploaded an animation previously with little to no jitter in it and haven't changed the export pipeline since. Is there a sollution to this or is it just a matter of waiting and hoping that it'll be fixed with future fixes :)?


(Waleguene) #9

Hi @SorenFalske,

Could you give more details about the issue on this model ? I don't see any shaking (maybe I missed it).

Thanks