Site crashes while trying to load Model

I get the same.

Windows 10. Edge and chrome

1 Like

Same thing happens to me, I am using Windows 10, Chrome and I have a RTX 3070 with a Ryzen 7 CPU

One thing I note. The main.js file makes a call to which remains pending with no return from the domain. Maybe this is a lead to why the page hangs and the 3D model does not load.

  • For Edge: [Brower doesn’t load 3D models anymore - #6 by james ]
    Tried this - no change. I tried turning protection on/off and whitelisting. Issue remains

  • ( is non blocking for render/loading)
    I don’t see any call on the network for the 3D object data. I see two network calls which both remain pending. Sentry and Ramen. I really think the process is stalling at this point

  • Firefox should work ?
    Not tried FF.

Same problem. I am using Windows 10, Chrome and I have a RTX 3060 with a Intel i 7 CPU

Another addition.

The viewers on other pages work. For example
Sketchfab Weekly, Sep 12: ‘Drink’ - Sketchfab Weekly - Sketchfab Forum

Here the models load without issue and work.

1 Like

Im having this problem to , has anyone found solution?

I’m having the same issue. The Sketchfab Weekly, Sept 12 link did work for me as well which is also weird. WebGL seems to be working otherwise. whats strange is it fails in Edge and Chrome, of which I only use Chrome regularly. No extensions or anything in Edge. Opera GX also works fine. I’m going to update my graphics drivers if for some reason it is that.

Did the updated graphics drivers solve the problem?

Hi Abby,

No it did not :confused:

I realized I had Opera GX installed and I tried that and it works for now. I’m not sure why both Edge and Chrome didn’t work but Opera is at least a fallback for now. I do prefer Chrome though for work. I tried turning off all extensions, clearing site data for but no luck.

Any other ideas of what I can do?


Same issue here, just as you describe.
Still can´t load Sketchfab on Chrome.
Any fix yet ?

1 Like

I’m putting together a cpu with 3080 and i7 with a Samsung 65” QN800a 8k monitor to look at photogrammetry datasets… the Samsung won’t load the models, so I thought it may need to be run thru a cpu with the 3080… is that the case or is it not going to make a difference?
I want the highest resolution possible and for it to load …

@sketchfab still have no solution for this?

Same issue here, past few days. Brave and chrome on win10, safari and chrome on iOS. Cant download the models on pc either since the page is frozen

Has anyone found a solution to this problem? I’m surprised it’s gone on this long TBH.


It’s 2023 and the problem is still present. I wonder if @Sketchfab are going to take a look at this this year?!

This is still ongoing, and I still think this is related to hanging.

Is there anyone who can take a look at this?

I have the same error on safari
full posted about this yesterday Unable to view model

Having the same issue. :frowning: