Sketchfab C4D Exporter Plugin Problem

Hello!
I am new here and I wanted to upload my rig from Cinema4D.
I’ve downloaded and installed the Plugin like it was written in the instructions…

But here’s the problem: I wanted to upload it, I went to my Plug-Ins tab but there wasn’t the exporter
plugin showing up. I’ve also checked and restarted Cinema4D several times.

The one folder is in the plugins folder and the one zip is unpacked in the python win64 folder.

I am using Cinema4D R13 and I have Windows.

Anyone has any tips? Thanks for now! :smile:

~Niestrat99

P.S.: Sorry, if I might have messed up some sentences, english is not my first language. :sweat_smile:

Hello!

I’m sorry you’re having trouble. There are some known issues installing the plugin on some machines and some versions of C4D. We’re investigating but we don’t have a fix yet :frowning:

For now, you can manually export and upload one of our supported formats, like FBX.

Hello, it’s me again! I just wanted to mention that I solved the problem.

Thanks for the support anyways! :slight_smile:
~Niestrat99

niestrat99 - how did you solve this problem ?
BTW interesting when Exporter will work with all C4D versions and all machines ?

1 Like

I had C4D R13, now I got C4D R16 and it surprisingly worked… I guess that you need a newer version of it

2 Likes

Hi James, any update on the fix to the C4D Exporter?

I’m on R18, OS X 10.12. C4D crashes immediately on hitting Publish.

If it is not working properly, maxbe re-install it or download it again? Either its C4D or the C4D Exporter should get an update.

In fact, since I’ve upgraded to R17, the plugin isn’t showing on the plugins list anymore.

No update yet, I’m afraid :confused:

These issues have been really hard to track down, and are probably related to changes in the C4D API in R17 and/or R18.

Thanks for getting back on this James… although disappointing to hear as the ease of workflow with the exporter was the main reason I went pro. Fingers crossed for developments soon.

In the meantime can you point me towards any C4D to Sketchfab workflow guide?

1 Like

I think @vrhuman has some C4D experience. Maybe he can help?

1 Like

Hi @JAMESMCDERMID3D,

do you have any specific questions I can help you with? As long as you use the C4D material system the exporter works pretty well.

Feel free to ping me anyttime you have questions :slight_smile:

The exporter itself has some installation problems on recent versions of C4D, but manually exporting and uploading FBX should work the same way. Regarding specific any material or animation questions, I’m not familiar enough with the software :confused:

Hi, The exporter still not working in Cinema 4d R19, so, that really sad, hope devs fix it in new versions

1 Like

Yeah I think R19 is too new for the exporter

Hi,

@deslancer @niestrat99 Could you give a try with this version ?

It seems that the exporter page is not up-to-date so you might have been using the old one, known to be borken.

Thanks,

1 Like

Hi, thanks, but this version not workin too
c4d show this message fff
Maybe you know, whats wrong?

Hi @deslancer,

Such issues have been reported several times by users but we have not been able to reproduce it so we don’t have any clue at the moment.
Which process did you use to add the plugin to Cinema4D ? Any details could give us some hints and maybe help us to provide a fix.

Thanks,

Thank god, I’ve been looking for this for a week… Finally this one is working with R19! Thanks a lot !