Sketchfab Forum

Sketchfab doing nothing for me on Oculus


(P3n T4g R4m) #1

Running Chromium with webvr enabled. Oculus CV1 set to allow external apps. Tried tests at iswebvrready.org, worked a treat. Launching sketchfab either from the portal or an individual model just brings the model up in a big window on 2-d monitor. Any ideas?

Oh, btw, my oculus goes dead at this point. Doesn't even go into Home, just a black screen. I have to kill the sketchfab window to get back in.


(Stephomi) #2

Did you try with the last build https://webvr.info/get-chrome/ ?
I just tried and it worked fine.

If you open the console (ctrl+shift+j), is there some errors at the end?


(Aleahy) #3

Hi, Chromium VR (55.0.2869.0) is also NOT working for me on Sketchfab with HTC Vive on Windows 10.

Browser goes into split view okay, but there's no tracking and the HMD stays in the Vive Arena.

A possibly useful warning is..

embed?ui_watermark=0&ui_stop=0&tracking=0&ui_snapshots=0&internal=1&autostart=1&ui_infos=0:1 Uncaught (in promise)
DOMException: Access to VR devices is not allowed in this context.

viewer-4073430….js:49 no hmd device provided to the viewer!

While we're in "things are changing a lot" world, it'd be awesome if everyone listed precisely which versions/platforms you have Sketchfab VR working on.

If instead I use ChromiumVR 54.0.2823.0 from Brandon's Archive folder (around 7 Aug 2016) on webvr.info, Sketchfab in WebVR mostly works okay. I still find the wand controller a bit hit and miss.

Andrew


(Stephomi) #4

@aleahy with the last version of chromium VR the launcher can't work currently, but the regular webvr button should work fine. This is something we will work on.

VR browsers and webvr specification are evolving constantly, soon it will be more stable but for now you shouldn't be suprised if the support is really stable.
It's not always something that we can control.


(P3n T4g R4m) #5

Thanks for the help, guys. Sorry for the hit and run posting but it was one of those weekends. So anyway, I checked the console and sure enough I'm getting the same "Access to VR devices is not allowed in this context" as aleahy. Will try downgrading chromium tonight.