Sketchfab Forum

Sketchfab embed on unity asset store issue

(Nickholl) #1


Im trying to embed some sketchfab scenes for an asset I'm bublishing on the unity asset store. (this is an example. )

The issue I'm having is that there seems to be some kind of auto rotate on it that doesn't appear when viewed from skethcfab :-/. The camera zooms straight past the object and then continues to rotate around.

Is this a unity issue or is it something that can be fixed sketchfab side?

thanks for any help!

(Nomadking) #2

Autospin is an embed option that can be set, so it could be that Unity are autosetting it for Sketchfab embeds on the Asset Store.

(Nickholl) #3

hmmm - thanks for that. Might ping Unity a message as well :slight_smile:

(Bart) #4

Yes I think you're right, I see it on other models too:!/content/50365

(Nickholl) #5

not holding out for a solution :(. Im guessing its something Unity have hard coded into their asset store code :-/

(Nomadking) #6

It does look like they made the choice to use autospin on all embeds (at least all the ones I could find). You could try using your Sketchfab URL with the autospin already set to 0.0 ( - the double parameters might stop it working or Unity might strip out the params before embedding.

Failing that, your best option is to setup your scene knowing the spin will happen and have both versions of your model in the center (the rotation happens around the center of the scene, which is why you get the odd camera behaviour with your model spaced out).

Not the solution you where probably hoping for, but seems like the best option given the circumstances :frowning:

(Nickholl) #7

How can I put both object in the centre? Do you mean next to each other in the centre? I guess that would be an option. Will try and get some kind of word from unity before doing anything :slight_smile:
thanks for your advice!

(Nomadking) #8

Yes, I mean rearranging your scene to have them next to each other.

Good luck!