Sketchfab Forum

Sketchfab not loading some parts of mesh

upload

(Marc Alburna) #1

Hi, first time writing here. I am facing this problem: I have exported amodel made in 3DS Max in .fbx, but when I try to upload it here in Sketchfab with its textures, some parts are just missing, even though all the model has the same material, or maybe 2 different materials (but even in this case some meshes are visible and some are not. The parts not visible are made using booleans, but I have already seen the "solution" changing them to editable poly, but the problem keeps going. In the 3D settings of the model the misisng parts appear when I turn off transparency, even though those parts have nothing of transparent of any type. But when they are "visible" they appear in black, and the textures are not showing.

This is what can be seen with transparency switched off:

https://sketchfab.com/models/e924bb7b6c584d1aa19f97656325c0a7

I even changed the format for trying something new, but the model appears broken on some parts. Any idea?


(riki) #2

When I click on the link, it says your model hasn't been published yet. Try publishing your model so others can give help!


(Marc Alburna) #3

Sorry, my bad. The model looks so shitty that I did not want it to be seen lol. Here it is.

https://sketchfab.com/models/e924bb7b6c584d1aa19f97656325c0a7


(Stephomi) #4

@marc.alburna In the editor, tab "scene", in "Vertex color", there's a checkbox with "Vertex alpha" that you can turn off.


(Marc Alburna) #5

Hi, tried to do this but as I export the model again in .fbx uploaded in sketchfab happens the same:


(Marc Alburna) #6

Here without transparency:


(Marc Alburna) #7

vertex alpha is unchecked and it is still going transparant in sketchfab and receiveing 0 textures


(Stephomi) #8

Argh, you deleted the model, I can't debug anymore :frowning:.

If vertex alpha, is unchecked and if there is 0 texture in your Transparency channel (and if the factor is stuck at 0 obviously), the mesh should definitely be visible


(Marc Alburna) #9

Sorry for deleting it, I am trying 2534654 things and it gets very frustrating...I know I will sound extremely noob, but in 3DsMAX, where can I find this transparency channel??


(Marc Alburna) #10

Published again if you wanna check it out. Sorry again.


(Waleguene) #11

Hi @marc.alburna,

Maybe this can help: you can render with the vertex colors in 3dsMax through Object properties:

and then enabling vertex colors:

Here you can switch from Vertex Color to Vertex Alpha etc.


(Marc Alburna) #12

Still happening even when I switch the vertex color channel off


(Stephomi) #13

^ hm I can see the hidden part reappearing when I switch off vertex color alpha.


(Marc Alburna) #14

Oh my goodness...THANK YOU VERY MUCH! I was thinking all te time it was a thing from 3ds MAX...godammit...:):):slight_smile: thank you very much again!


(Marc Alburna) #15

final result. Thank you guys!!