Sketchfab plugin not working in blender 2.80 since lastupdate


(Valeri Che) #1

Yesterday after updating blender 2.8 to latest build sketchfab plugin not working anymore.
Error message:

Traceback (most recent call last):
File “C:\Users\Admin\Desktop\blender-2.80.0\2.80\scripts\modules\addon_utils.py”, line 393, in enable
mod.register()
File “C:\Users\Admin\AppData\Roaming\Blender Foundation\Blender\2.80\scripts\addons\io_sketchfab_plugin_init_.py”, line 1263, in register
bpy.utils.register_class(cls)
RuntimeError: Error: Registering panel class: ‘VIEW3D_PT_Login’ has category ‘Sketchfab’

Must be something regarding API changes i think.


(Waleguene) #2

Hi @ValeriChe,

This issue has been reported yesterday and we updated the 2.8 plugin on the release page, and we updated it to make it work with latest version.

Please note that the release workflow of the plugin for 2.8 is a bit special:

As Blender 2.8 releases are pushed on a regular basis, it can happen that an API change breaks the current plugin from one version to another, but we cannot do a new release each time.

So, the current plan is to test on a regular basis with the latest version to see if everything is ok, and if it’s not, we:

  1. Update/fix the plugin for the latest version
  2. Replace the io_sketchfab_plugin-Blender-2.8.zip file on the latest release page
  3. Update the release notes to specify on which version the plugin has been lastly tested.

We will also follow user reports as much as possible in order to quickly provide a fixed version. If your version is more recent than the one mentioned in the release notes (checking the date is enough), please report so that we can check and update it :slight_smile:

Thanks