Sketchfab slow in loading models


Thanks for looking into this. Using the chrome://gpu link you provided, I have pasted the report below.

If it helps to know, I have tried loading models in Firefox, Internet Explorer, and MS Edge and have not experienced the delays in loading. Also, I have not experienced the delays when accessing models which are embedded on webpages, even when using Chrome as the bowser.


1 Like

@danderson4 I think that if you reply by email, attachments aren’t posted on the forum. Could you email the report to please?


Just sent



Thanks Dave!

1 Like

Bug filled on chrome reports, they try to reproduce and investigate

(for now they have hard time reproducing it)

Wanted to provide a quick update. I have looked over the log on the ticket and based on the information in Comment 10 I did the following:

  1. Updated drivers for Intel UHD Graphics 630 GPU to latest driver provided by Dell, the computer manufacturer. Version now installed is

  2. Updated NVIDIA drivers for the NVIDIA 1070 to latest driver from NVIDIA. Version now installed is 461.40

Attempted to run Chrome from command line with the parameters provided and received message “Google Chrome cannot read and write to its data directory”

After these attempts the SF interface still unresponsive for 10+seconds before model starts to load. Rechecked Edge and Firefox and responsiveness and model loading is nearly instantaneous.

Further information:
Computer is a Dell Alienware 17 R5 laptop.

As stated earlier, this machine has not had the problem until about a week before my original post date.

There is also a 12 second delay of unresponsiveness when attempting to change 3D Settings on a model. This delay includes none of the settings options on the left to load until after the delay.

Thank you again for all the help and your continued efforts to solve the issue.

1 Like

Hello again,
I have done some more “investigating” and in trying different scenarios have found the following:

First Scenario

  1. I open Chrome and go to in a tab
  2. Try some models and they are unresponsive as previously reported.
  3. Then open new tab in Chrome and navigate to a webpage with an embedded Sketchfab model such as this model loads on the webpage immediately and is responsive if clicked. I can manipulate the model very quickly. As quickly as before this problem started.
  4. Click this model to open it directly in Sketchfab and the model loads quickly and interface is nearly instantly responsive.
  5. open a new chrome tab and go to and open a model (any model) and interface is nearly instantly responsive.
  6. If I go back to my original Chrome tab where I first went to, any new models I attempt to open have the interface nearly instantly responsive.
  7. I can open new tabs and go to and the interface is nearly instantly responsive as it was before the problem started.
  8. Please note that if I do not manipulate the model on the webpage where it was embedded, but only look at the static image, this scenario of the interface becoming responsive does not work. I have to manipulate the model (rotate it) first before heading over to by clicking the icon or the model name link for this to work.
  9. close chrome and then reopen and go to and the problem is happening again.

Second Scenario

  1. Open Chrome and immediately go to a webpage with embedded model without first opening sketchfab in a tab.
  2. Model embedded on the page is instantly responsive.
  3. Click the SF icon or the model name to got to and the interface lags and is non-responsive for 10+seconds.

So, it appears to work as expected only if I first go to on a tab and leave that tab open and THEN “use” a sketchfab model embedded on a webpage and then use a link from that model to open a new tab in Then the new tab, the original tab, and any new tabs I open of perform as expected without the lag or unresponsiveness. This works as long as I keep the instance of chrome open. As soon as I close Chrome and then start a new instance, this doesn’t not work and unresponsive is happening again. I can also report that if I do scenario 1 in one instance of Chrome and then open another and another and another instance, all the instances of chrome perform as expected without a delayed response in the interface. If I close them all and start again the problem starts again.

I hope this may help you all in trying to identify the underlying problem

1 Like

Thanks for the very detailed report, will forward to google team!

1 Like

I am also having this issue, win10, chrome. Model loads endlessly, then “Page Unresponsive” dialog from Chrome. Sketchfab worked just fine on this very beefy PC until a week or two ago. Works fine in Firefox, as well as Chrome on other computers.

I attempted but was not able to replicate your fix, @danderson4. I’ll try it again.

From the thread, it sounds like the problem is on the Chrome side? :expressionless:

1 Like


Unfortunately, I still have not been able to get a fix. The information that I relayed was only an observation of some of the strange ways that Sketchfab was performing. It has to be a problem on the Chrome side but I don’t know what it is and have not gotten any answers from the thread that Sketchfab started with Chrome support. It is very frustrating as I typically use Chrome as my browser, but then have to reopen everything in Firefox to get it to load efficiently.

If you get a solution please, please, please let me know and I will do the same.

1 Like

Yes this happends me too.

Is this happening on a specific model, or everywhere? Please provide as much detailed information as possible to help us investigate.

I’m having kind of the same issue, if I try to load the sketchfab main page or a model page, the site freezes and the model doesn’t load, it’s stuck on the loading screen. But if I go to any website that has an embed viewer, I can click on the viewer and the model loads and I can interact with it, if I click to open the model on a new tab, the problem happens again. I tried to access a model using chrome or Microsoft edge and in both browsers, that happens. I tried activating the hardware acceleration and the chrome:flag ignore blacklisted and it still doesn’t work on the sketchfab domain, only the embed viewers work. Also, that happens with any model. I tried to reproduce the steps that danderson4 said could solve it temporarily (opening the main website and then opening an embed viewer and it turns responsive) but it didn’t work

Hi, as we don’t reproduce, it would help if you could provide more details:
Could you post a video showing the bug ?
Could you post a screenshot of a

I’m also having this problem. I’m not able to view any models directyl on sketchfab. Embeded models such as the link danderson4 shared appear to work, but thats all. Strangely this issue is in both chrome and edge.

Hi, as we don’t reproduce, it would help if you could provide more details:
Could you post a screenshot of a
Thanks ?

Sure, do you need the supported extensions bit as well.

Thanks very nice, it helps (no need of extensions)

Sorry to bother can you try to reproduce the bug in “incognito mode” of the browser ?

Hi Paul, it’s strange, but the bug isn’t happening anymore, maybe it was solved because of the last chrome update? If it happens again, I’m gonna record a video of it and send the screenshot.

1 Like