Sketchfab upload error: cannot get returned uid


(Reuldereut) #1

Good day, I am trying to use the Sketchfab plugin for Zbrush but it always fails at the zipping part with the follwoing error message:

sketchfab upload error: cannot get returned uid!

would you know how I could solve this issue?
thank you,
reul dereut.


#2

My first guess is that the model is too big for your account's file size limit. If you export the model manually as OBJ(s) + MTL(s) + texture(s), and ZIP them all together, how big is it?


(Rustymyers) #3

I've been getting the same error in ZBrush. It seems that the models do get uploaded, although seem to be missing some layers. It's possible I just don't know what I'm doing, but I've used an example model and just tried uploading that and it gave me the error.


#4

We'll be updating the ZBrush exporter in the near future. Then it will be much more resilient.

For now, you can export and upload manually as OBJ + MTL?


(Seanforsyth) #5

Hi James, any idea when this exporter will be updated? It doesn't work at all in the 64 bit version of ZBrush, and the 32bit has a few problems. It doesn't do the decimation step properly and the upload also fails with the error about returned uid as mentioned above.

Look forward to hearing from you, it's an awesome plugin, just needs a little love!
S


(Bart) #6

Hi @seanforsyth! James is out of office for a few days, and I don't know the status of the exporter. He'll get back to you later this week.


(Seanforsyth) #7

That's great Bart, thanks for letting me know.


#8

The exporter's developer has started work on this. I'll follow up with more information as soon as I have it.


#9

Update: We have a beta version that I'm testing. It's working well, so we hope to release it soon.