Sketchfab Upload Failed. Error: 400 Bad Request


(Tyson Gersh) #1

I don’t know what the problem is, but I’ve wasted the last 1.5 hours trying to get a relatively simple model to upload. I keep reducing the file size by removing materials/textures and retrying, but no luck. I’m well below the file size limit. What’s the problem here?

Here’s a link to the model itself: https://drive.google.com/file/d/1J3DeQnCgf9ioLkZrMo4UybiIq4GyBWdj/view?usp=sharing

I’m using the SketchUp Exporter just FYI


#2

I just tested and it worked, but because of some of the HUGE texture files, you’re probably going above your 200MB limit.

38M  grey_concrete_22_diffuse.png
36M  beige_stone_stone_25_diffuse.png
27M  grey_concrete_14_diffuse.png
27M  grey_concrete_01_diffuse.png
14M  grey_metal_04_reflection.png
13M  grey_metal_02_glossiness.png
9.7M green_painted_metal_01_diffuse.png
9.0M sandydrysoil_albedo.png
8.1M grey_metal_03_glossiness.png
862K Neopor3__1_.jpg
56K  Grass_Dark_Green.jpg
42K  Steel_Brushed_Stainless.jpg
16K  Densglass_Gold.jpg

Some of those are way too big for textures, so there’s probably an opportunity to compress them.


(Tyson Gersh) #3

Any idea why it worked for you, but not for me? I bought some fancy textures to try and up my modeling game. The file size was only 188mb though, so I should have been fine, right?

I removed another texture reducing it down to 150mb and it says it worked this time.

The PBR textures come in folders like this:

What’s the best way to compress them? Is that even possible while using the SketchUp Exporter?


#4

My upload limit is 500MB.

The .skp file is 180MB, but that’s irrelevant. The package that is actually uploaded by the exporter is a Collada (.dae) file + textures, zipped together, and it ends up being about 206MB. You can test this by manually exporting Collada, OBJ, or another format.

You could convert them to JPEG. You could also just manually upload the file + some of the textures and add the last ones in 3D Settings afterwards.


(Tyson Gersh) #5

So, I tried converting some of the heavy textures to placeholder colors in SketchUp with the intent of applying the texture itself to the model via the material settings editor in SF.

It’s just a grayish color during import:
22%20PM

But when I apply the textures themselves, they aren’t actually loading for some reason.

Here’s the texture I’m trying to apply:

As far as I can tell it has been uploaded properly along with the appropriate supporting glossiness, specular, and normal, but for some reason it’s just rendered as a flat color:
37%20PM

Here’s the link to the model itself: https://sketchfab.com/models/715f0f1dafb540e1a38a49a937a4f926

Any idea why it’s not working?


#6

Hey, I think we discussed over email, but it seems that good UVs aren’t exported when it’s just a placeholder color, it needs to have a texture applied.