Sketchfab viewer lighting bug

bug-report

(Penny) #1

Hey all,

I'm getting a weird lighting bug viewing this model on a particular machine. I have a couple of lights set up in the scene.

Here's what it looks like behaving correctly:

Here's what it looks like on that machine:

Shadeless and Matcap mode works fine:

This happens regardless of LD/HD textures. Here're some specs of that machine:

OS: Linux dell 4.8.13-1-ARCH #1 SMP PREEMPT Fri Dec 9 07:24:34 CET 2016 x86_64 GNU/Linux
Browser: Firefox 50.1.0-1
GPU: [AMD/ATI] RV730/M96 [Mobility Radeon HD 4650/5165]
Misc: Arch Linux, xorg-server 1.18.4-1, mesa 13.0.3-1

The GLXInfo is attached below. Thanks!

glxinfo (15.6 KB)


(Nihal Rahman Nahin) #2

Either The Boewers / PC Has Compatability Issues


(Stephomi) #3

Do you reproduce the issue on chrome?


(Penny) #4

Ah, we'll get Chrome on here and try reproducing it tonight. Thanks for the response!


(Penny) #5

On Chrome, 3D wasn't enabled by default and we had to manually enable 3D acceleration. When that was done, 3D worked fine, but the same lighting problem persisted.


(Chaitanyak) #6

@fenelope i actually have been having that bug on my machine ever since the nvidia graphics card crashed.. have been using the integrated graphics(intel hd graphics) to get work done.. and alls fine, but i have that same pink color issue on anything that has normal maps.
eg:


heres the model -

it looks fine on other machines and even my 3yr old android phone (Nexus 5 with Adreno 330 and Snapdragon 800).
therefore i surmise its to do with graphics drivers or struggling hardware(in my case the integrated intel graphics)

in your case.. i'd guess it would be the drivers for your ATI card or maybe webgl on your machine is not using the ATI card at all.. and falling back on your integrated graphics?