Sketchfab WordPress plugin setting

editor
viewer
3d

(Maisam Fathi) #1

I want Change 3d environment color with shortcode or other ways in my site. I changed some setting in "3d setting" of my model and I can put a black environment but I need change it with other colors. Also I see black background in "sketchfab.com" but it is not affected on my website (www.sangabco.com). I use WordPress 4.4.2. Thanks for any help about it. /Regards, Maisam


#2

Hello,

Soon, you'll be able to choose any solid color as the background of your model. This should be a better solution than your current black background from a 0 brightness environment.

It's not the same on your website because you added &transparent= to the iframe src. You should set it to &transparent=0 or get rid of the parameter completely. Currently you are hiding any background and using the color of your website instead.


(Maisam Fathi) #3

Hello dear James,
Thank you for your comments. I turned off transparent parameter on 3D Setting and change the background mode on color but, It work good on www.sketchfab.com and didn't work on my website (www.sangabco.com). I can see the background color that I specify, only when the 3d model didn't load on page and when users click Play button and want to see it, It became white.


#4

Hi,

You still have transparent enabled in your iframe src. Just make it transparent=0 to fix it: