Sketchfab's AR mode doesn't look good. Is there not a fix for this? Or do I have to move to Unity?


(Costa P) #1

Hi
I am a VR Dev with an interest in Medical Health. I have created some body organs and this is what they look like in Sketchfab:3D models by Constantinos Panayi (@CostaP) - Sketchfab

I tried Sketchfab’s AR mode, and although it looks ok, the lighting is not brilliant. This is the only post that mentions this issue AR Lighting Options , so am unsure if there is a fix.

Is there any fix for this or will I have to move to Unity/Vuforia?

This was the Sketchfab lighting issue I was having in AR mode:


(Rémy Bouquet) #2

Hello.
In AR mode we change the lighting to use only the environment and add a light from above for the ground shadow. So all your static lights are ignored.
We did this to avoid complex lighting settings to contrast too much with the AR scene and make it “unnatural”.
You can try to boost your environment light intensity in the editor, and experiment with the settings.