SketchUp Model Processing and Performance

tutorial
sketchup

#1

Update - There is a SketchUp Extension called Bomb that can handle this process for you:

https://extensions.sketchup.com/en/content/bomb


There is a common problem with SketchUp models due to the way its Components and Groups are handled. They are interpreted as thousands of separate objects, which causes our processing to fail. Or, if processing succeeds, it really hurts viewer performance. The biggest culprits here are trees and plants, which are very complex Components nested in Components nested in Components...

If you're using the Exporter or manually exporting as COLLADA (.DAE), the easiest thing to do is DISABLE Preserve component hierarchy

Another, more manual solution is to Explode all your Components into their basic faces/edges.

Go to Window → Model Info, and go to the Statistics tab. Make sure Show nested components is checked. Here, you can see the number of Component Instances. You'll want to reduce that as much as possible, ideally to zero. This can take some time, and makes the model difficult to edit, so it should be the final step before uploading.

Select All, or just a few Components at time ( It can be quite CPU/memory intensive ), and do Edit → X Components or X Entities → Explode. Repeat until there's nothing left to Explode and the whole model is a single mesh.

This will greatly improve upload/processing time and viewer performance. I've never seen it mess up textures/materials. Be sure to also check out the SketchUp exporter:

https://sketchfab.com/exporters/sketchup


Sketchup models are not prefectly converted
Sketch up model to sketchfab
Sketchup 2016 Model Upload Error
Performance difference
Upload from SketchUp - Colors issue
No textures and colors in my model
Issue transferring Sketchup model to Sketchfab
Flipped Normals Error When Uploading Models..?
Sketchup model failing to upload
Material IDs not updating or showing all
A problem when uploading my model
Requesting Tips and Ideal methods to upload larger SketchUp models
Help! Flickering textures?
Can't load model on iphone
Materials incorrect upon upload
Uploaded .skp has no textures on it
Cannot get some parts of a model to display texture
Everything turns out white on upload (from 'built-in-uploader in SketchUp)
Sketchup model completely white
Uploading With Sketchup 2014 Problem
Annotation movement not smooth