SketchUp Model Processing and Performance

Update - There is a SketchUp Extension called Bomb that can handle this process for you:

https://extensions.sketchup.com/en/content/bomb


There is a common problem with SketchUp models due to the way its Components and Groups are handled. They are interpreted as thousands of separate objects, which causes our processing to fail. Or, if processing succeeds, it really hurts viewer performance. The biggest culprits here are trees and plants, which are very complex Components nested in Components nested in Components...

If you're using the Exporter or manually exporting as COLLADA (.DAE), the easiest thing to do is DISABLE Preserve component hierarchy

Another, more manual solution is to Explode all your Components into their basic faces/edges.

Go to Window → Model Info, and go to the Statistics tab. Make sure Show nested components is checked. Here, you can see the number of Component Instances. You'll want to reduce that as much as possible, ideally to zero. This can take some time, and makes the model difficult to edit, so it should be the final step before uploading.

Select All, or just a few Components at time ( It can be quite CPU/memory intensive ), and do Edit → X Components or X Entities → Explode. Repeat until there's nothing left to Explode and the whole model is a single mesh.

This will greatly improve upload/processing time and viewer performance. I've never seen it mess up textures/materials. Be sure to also check out the SketchUp exporter:

https://sketchfab.com/exporters/sketchup

2 Likes