SketchUp Pro 2017 DAE File Does not Load Properly in Sketchfab


(Ntxdave) #1

I was testing the ability to export a DAE file which could be used in Sketchfab. With SketchUp Pro 2016 the DAE file can be uploaded to Sketchfab. However when I try to export the same file using SketchUp Pro 2016 the upload gets an error and the upload will not work. I do not see any indication in the failure message about what the error is.

The same file works fine with the SketchUp Sketchfab Uploader plugin in SketchUp Pro 2017 which is fine except that I cannot use the uploader plugin if I need to re-upload a file.


(Mrchlblng) #2

Hey @ntxdave,

I looked at one of your latest upload that failed and it seems like the file you upload is empty (like it litterally is 0 byte).

We definitively need to improve our error messages to help you have a more helpful feedback. It's logged but no ETA for this yet.
We also need to improve our exporters to add the ability to reupload models. It's also something that we're aware of but do not have ETA yet.


(Ntxdave) #3

Someone in the SketchUcation forum suggested I try a couple of different settings which I just did and get the same results. The DAE file stored on my hard drive is definitely not empty. I think that this is another example of something that has changed in SketchUp 2017. I would like to suggest that you try to have a discussion with the support staff at Trimble to see if they are doing something different. I tried 2 different models and both of them failed with Error 13.


(Mrchlblng) #4

Apologies, I went a bit too fast this morning; the file we try to process is empty because decompression fails.
Do you zip it yourself? If so, could you try to upload the file directly and otherwise, could you zip the file yourself (using either zip/rar/7z) before uploading?

Using another tool to decompress the file, I can say that it will process just fine (see https://skfb.ly/XJHQ).

Sorry about that. It's an issue we've seen sometimes and did not yet tackle as it easy to bypass once it's identified.


(Ntxdave) #5

I did not compress the file. I just used the native Export>3D Graphic> as a DAE file in SketchUp 2017. This same model exported just fine from SketchUp 2016 that is why I suggested that you might try to talk to the SketchUp Support Team at Trimble to see what they might have changed in the export process.

Yes, I was able to view the file after you uploaded it just fine. Of course, I cannot edit the 3D settings but if we can get this working correctly it provides another alternative even though the Sketchfab Uploader plugin seems to work fine with 2017. Perhaps Alex Schreyer (the author of the plugin) could shed some light on the subject since I think his plugin converts the SketchUp SKP file to a DAE as well.

That would bring up an interesting discussion as well. Since that is what his plugin does but his code does not allow us to re-upload a model, maybe the conversation between you guys could escalate the process of getting his plugin to allow the re-upload process.

I have to tell you that as I continue to learn how to use the tool better, I think it is pretty neat. I have a couple of very simple models (one I uploaded with Ale's plugin and one I uploaded from 2016 as a DAE file) that have some shiny metal which has been something I was struggling with.

Here are the links:
SketchUp Sketchfab Uploader Plugin version
SketchUp Pro 2016 DAE version

Let me know what you think :grinning:


(Mrchlblng) #6

@ntxdave thanks again for the feedback. If you manually zip the file before you upload it on sketchfab, you should be fine. The issue you encountered is due to our javascript code zipping your data before upload; it sometimes create "bad" archives that we fail to process. It's a known issue that happen rarely from what we know and that we'll eventually fix.

Regarding the exporter, @james could give you more details but I believe we're already talking with Alex for some updates on the plugin. We currently have no plugins that allow to reupload but that's definitively something we'll do. It's mostly a matter of finding a good UX for this, making sure it's feasible in most softwares.


#7

I talked to @alexschreyer last week and a new version ready for SketchUp 2017 should be in the Extension Warehouse soon, if not already.

Exporters that allow re-uploading is a huge goal of mine, but it will be a tricky upgrade.


(Ntxdave) #8

@mrchlblng Thanks for the reply. I will try compressing a little later and see what happens. The only reason I was even looking at the DAE was because of the re-upload feature. I wanted to clean up a model that I had already sent someone a link to.

@james I had already installed the latest version (2.3) but I updated it again just to be sure. Everything seems to work fine. I look forward to the day when I can re-upload a model because there are times when things change and rather than have to specify/share a new link, I would like to just be able to update an existing one.

I want you guys to know that I appreciate the follow up you are giving.


#9

Maybe I spoke to him longer ago that that, I don't remember...

Glad you got it working!


#10

@ntxdave could you upload a very simple SketchUp model that throws the same error? A small model file will help us debug more quickly and get this fixed.


(Ntxdave) #11

I did some more testing this morning and I did not get any of the previous errors so the refresh of the uploader must have done the trick. I uploaded 4 models ranging from super simple to rather complex and I was able to get them all uploaded.

I did have one problem. This model https://skfb.ly/XUBM is not correct. The original SketchUp file (see below) has 6 materials but the uploaded model only has one material.

Here is the SketchUp file that did not load correctly:
Sketchfab SketchUp 2017 Test.skp (73.6 KB)


(Ntxdave) #12

OK - I did some more testing. All of the files I generated before were with the Sketchfab Uploader version 2.3 in SketchUp Pro 2017. Then I reared the topic and think what we were really discussing was when I used SketchUp Pro to generate the DAE file and then tried to upload it. I got one to work (just a cube but the colors did not come out right). It is the SKP file I posted in my previous post.

I just now tried to upload another DAE file created with SktechUp Pro 2017 and was back to the same Error 13. So I am attaching the SketchUp file for this one. TopBrush-DCW-2017.skp (889.0 KB)

Here is the DAE file that SktechUp 2017 generated.
TopBrush-DCW-2017.dae (8.1 MB)

Hope this helps resolve the problem.


(Mrchlblng) #13

@ntxdave sorry for the long silence.
Regarding the random "Error 13", we've prepared a fix that should go live hopefully this week.

As for materials, we indeed have a special treatment for Sketchup models during which we merge similar materials for performance reasons. This is something that should change soon as we're working on optimizing models based on user defined materials; when this is done, we could remove our Sketchup optimization (when the number of materials is "reasonable").
In the meantime, if this is an issue for you, you should be able to bypass this by exporting to another format than collada (as we only trigger the optimization for collada generated by Sketchup)


#14

As long as you have SketchUp Pro, you can export OBJ instead.