(Slight) issue with ZIP files downloaded to a Mac

website

(Jerryfisher) #1

I've noticed that when I download models from Sketchfab, they come as ZIP files but the problem is using the built-in Mac app "Archive Utility."

If a Mac user simply double clicks on the zip file after it is downloaded, they will go into a endless loop of ZIP files inside ZIP files inside ZIP files. I don't know why, but I figured out a kind of clunky solution.

For Mac users, go the App Store and use the free utility "The Unarchiver" instead. It doesn't seem to have the same issues with ZIP files from here as Apple's "Archive Utility" does. It will unpack the ZIP file properly.

I thought this might be of some interest as another person just contacted me in the last half hour to ask me the same question.


#2

Hi Jerry,

I'm a big fan of Keka, and I tend to use .7z for everything because it's even smaller (also supported for upload on Sketchfab!)

That said, I just tried to reproduce this issue with Archive Utility, but it worked fine. You see this on all model downloads? Could you send an example link?


(Jerryfisher) #3

Hi James,

Please check out this video I just created a few minutes ago.

It shows what I’ve encountered. I’m running Mac El Capitan 10.11.5 with all the updates. My Mac is a 2009 Mac Pro, 3.33GHz Intel with 32GB of RAM. I replaced the stock GPU with a Nvidia GTX 960 with 4GB of built in RAM. I’m befuddled as to why I and at least one other person have ran into this hiccup. If you check out the conversation at my model for the Head of a Satyr, 1st century, you’ll see what why I posted the note in the forums:

Head of a Satyr, 1st century by jerryfisher on Sketchfab


#4

Sorry, the video is private and I can't view.


#5

Regardless, I was able to reproduce. Thanks!


(Jerryfisher) #6

Sorry about that James. I'll switch it over to public, but glad you were able to reproduce it.