Slow model loading time on PC

Hey guys,
since a while ago models started loading very slowly on my PC. For example this model here took 7 minutes to load, and another 7 minutes to stream in the textures after initial load. The same model loads on my mobile under 5 seconds, using the same internet connection. I am on Windows, Chrome (also tested with Edge). Although I can’t be sure, it seems to me that the problem is even worse when opening a model from a large collection, for example my photogrammetry collection which has 1500 models, the more I scroll down in the collection, the slower the loading of the the models I click on (at least seems to be the case). Also I didnt have this issue few months ago

I will post the console message and loading times here:

processModelJSON : 0.60ms
Download file.binz (Async) | createAndInitFeatures : 54.50ms
Download file.binz (Async) : 86504.80ms
JSON.parse file.binz : 0.20ms
osgDB.parseSceneGraph file.binz (Async) : 3.40ms
UserDataVisitor file.binz : 0.20ms
Download model_file.binz (Async) : 446450.10ms
Uncompress model_file.binz : 124.30ms
initSceneGraph - create saved materials : 23.30ms
initSceneGraph - processSceneGraph : 1.00ms
initSceneGraph - apply materials : 3.60ms
optimizer | optimizer - materials : 0.70ms
| optimizer - nodes : 16.50ms
| Geometry count : before 4, after 4 | Material count : before 3, after 3
optimizer : 18.00ms
featureFinished | drawFirstFrame : 32.70ms
| compute KdTree : 153.50ms
| drawSecondFrame : 144.10ms
featureFinished : 396.20ms
wait async : 1.10ms
Bound center : [ 1.1772208213806161, 5.741624951362609, -7.4145536422729466 ]
Bound radius : 21.783128998648138B
box min : [ -10.759300231933594, -12.364521861076357, -9.461898684501644 ]
Bbox max : [ 13.113741874694826, 23.847771763801575, -5.367208600044249 ]<<<<< Model
Displayed! 973.1912999999998>>>>>
​ Texture packing FBO Count : 1
​ Download model_file_wireframe.binz (Async) : 26292.20ms
​ Uncompress model_file_wireframe.binz : 15.30ms
​ optimizer - wireframe : 2.40ms

I can’t reproduce that here, but I’ll pass this issue along to our web team!

1 Like

We’re not able to reproduce the issue and it appears to be isolated to your computer. We have run into similar situations before with virus checkers though - could you try disabling it for a second and see if that makes a difference? It could be a virus checker browser extension too.

Thanks for answering again. I tried turning off firewall/ anti virus, and turning off all my browser extensions. Also tested with firefox on top of chrome and edge. I also tried some other stuff like flushing the DNS cache since sometimes DNS wasn’t responding, nothing worked. Since it is from my side, I will continue looking for a solution. Thanks for your time

2 Likes