[solved] Wordpress Sketchfab Plugin: Private Models - Entering Password does not work


(Print Your Mind) #1

i,

chances are that i just did something wrong, but i think there is a bug in the wordpress plugin.

When I embed a private model in a wordpress blog with the sketchfab plugin i am asked for the password as expected, but when i enter the correct password and press Enter or click on Ok nothing seems to happen.


A Post to https://sketchfab.com/models/3437e9fd0a9e4d9493e8afd6bcd65a61/embed/password?autostart=0&autospin=&controls=1&transparent= is made and returns Statuscode 200 but im still presented with the input box where i can enter the password:

This is not the case when i have a regular embeded viewer (via oembed). What is funny however is, that setting the password seems to work. Because as soon as i open the same password protected model in another browser tab in a regular ebmbeded viewer it shows the model. So i suppose the auth cookies have been set. Once i have seen the model in the second tab i can reload the first tab (with the wordpress plugin) and the model is showing.

To test this it is important not to be logged on to sketchfab and to clear cookies.

Hope this helps.


Placing private models on a website
(Bart) #3

Confirmed - I can't get this to work with a regular HTML embed either:

https://dl.dropboxusercontent.com/u/150286/tmp/Sketchfab/teapot-private.html

(Password = 'hallo'). I'll ask our developers to look in to this.


(Print Your Mind) #4

that i cannot confirm. This is only true in Internet Explorer. Your example works fine in Firefox and Chrome. The wordpress-plugin works in no browser..


(Bart) #5

@print_your_mind it seems this has to do with certain browser settings blocking third party cookies. Could you try this: visit sketchfab.com first, then return to your page and enter the password. Does that unlock it?


(Print Your Mind) #6

@Bart: No it does not. Only if i actually log on on to sketchfab. (Does not have to be the account of the model-owner). If i dont log on the behaviour is the same.
I could pm you the login-data (http basic since we still try stuff) to the wp-blog so u can check it out yourself


(Bart) #7

Ah sorry to hear that. Yes, please do PM me the info


(Print Your Mind) #8

Btw: I tested in Chrome/Firefox. recent versions, standard cookie settings
i dont have the same problem if i test it with a regular embeded model

wordpress-plugin does not work with private models / curren oembed does => maybe wordpress-plugin does not use the same code to embed the model...


(Bart) #9

@pap here's more information on that private model. I have @print_your_mind's login info if you need it.


(Pierre-Antoine) #10

@bartv sure, send me the info


(Pierre-Antoine) #11

@print_your_mind can you check if it works if you remove the embed parameters (autostart, etc). I think I spotted the issue, just want to make sure. Thanks.


(Print Your Mind) #12

@pap yes, if i just embed it like this: [sketchfab id="a8371f069a5e4318bccf07b39dccfa24"]
the password problem is gone.


(Pierre-Antoine) #13

@print_your_mind quick update. We deployed two changes:
- an update fixing the issue for embeds with parameters
- when the browser blocks cookies in an iframe, we'll now display a warning message in the frame, and ask the user to go to the main website.

Happy to have you feedback on that.


(Print Your Mind) #14

@pap yes thank you! Works as expected now.