Some strange bug with normal map

Hi!
I tried to upload new model but after applying normal map I get strange result.
I reuploaded the model a few times messing with fbx and textures but didn’t get it work.
Then I uploaded same model (same fbx and textures) that I already published some time ago without any trouble and get same issue.



Model without bugs: Old Hatchback - Buy Royalty Free 3D model by Azusa (@azusanyan1992) [3979a5d] - Sketchfab Store

1 Like

First thing that came to my mind was: probably modified normals on the mesh, but since you mentioned that you tried older version of FBX and textures, I am in doubt now :confused:

Did you try this on Marmoset Toolbag, does it have the same results?

Yes I tried Marmoset and it worked well. I didn’t touched normals, even tried to reset them but nothing worked. Tried upload using opera and firefox - still same result.

hmmm… strange. I just checked your model in 3d and it looks OK on my screen

or is this the old model without any changes?

Really good model BTW! My dad used to have one :smiley: though it didn’t look as rusty as this one :smiley:

This one is without bugs
Here I published bugged version: https://skfb.ly/6QYJR

Thanks :blush:

Hmmm… I will have to think about this one :thinking:
Could be a bug, or something else unnoticed

Hi,

We introduced a regression on tangent processing in latest sketchfab update, that cause those visual glitch on normal maps.

It should be fixed in next Release, sorry !

5 Likes

I have the same problem. but I thought I was doing something wrong.


but in other softwares, this problem did not show itself

Thanks for creating a topic.
I hope with a new update, the model will not need to reload.

We will reprocess any affected models once the fix is live. Hopefully tomorrow, but possibly Monday.

2 Likes

Hello,

This issue has been resolved.

2 Likes

Hi
sorry guys, but it got worse.
maybe I’m doing something wrong, but after entering the “3D settings” artifacts appeared on absolutely all materials.
I reloaded the normal map image, no result.


look at that in Surface mod

I did not reloaded the model yet

everything is fine. reloading the model solved the problem
thanks!!!

2 Likes