"Something went wrong with 3D Viewer"

I’m getting this error (pictured) with every model I view on Sketchfab. This issue just started this week, and I was perfectly able to view models normally last week. The issue persists on Edge, Chrome, and Firefox. The image is low quality, and I can only rotate the model left and right, no other movement. I don’t get most of the options for viewing I normally get.

When I click the “Learn how to fix it here” link, it goes to a page troubleshooting WebGL, but when I check to see if WebGL is working, it works perfectly on all three browsers I tested.

What could be the issue here? Thank you for your time and help.

Seems to be a system wide issue if you’re getting it in multiple browsers. Have you tried updating your graphics card drivers? Or rolling them back if they’re recently been updated?

1 Like

Thank you for the reply. As you suggested, I tried rolling back my drivers, since I had recently updated the drivers to my NVIDIA 2070 Super. I rolled it back three times testing out both Game Ready and Studio drivers. The error on Sketchfab persists.

Any other ideas? I really appreciate the help.


WebGL
Sketchfab is telling me WebGL is not compatible with any of my browsers, yet the WebGL page says WebGL is working on all three browsers. This sure is weird. :slight_smile:

@David.Tveraas what reports do you see for webgl 1 and webgl 2 from here https://webglreport.com/ ?

2 Likes



This is what I see for both tabs

Anyone know how I can report/escalate this issue? It is hindering my ability to edit my uploads.

It’s the weekend, but I’m sure Tom (@nebulousflynn) will check back in on this on Monday.

You could also contact support directly either by opening a ticket (https://help.sketchfab.com/hc/en-us/requests/new) or by emailing support@sketchfab.com - but I’m not sure either would get you a quicker response over the weekend.

1 Like

@David.Tveraas hello again!

Sorry one more thing that I should have asked for: can you share your operating system and graphics card setup as well?

Also be sure to have checked common issues described in this help center article.

For what it is worth, I have accessed successfully your 3D model on two separate machines via Chrome, Firefox, and Edge.

Hello, I appreciate the help. I’m using Windows 11Home v22H2 build 22621.1702 and my graphics card is a NVIDIA 2070 Super running driver 31.0.15.3179.

I searched through the help center article and I could not find anything which would apply, so I hope I did not miss anything. I know the viewer is working for other people, because I’ve seen it. It was working from me up until about a week ago. I’ve tried rolling back drivers, uninstalling other programs, and a whole bunch of browser setting variations, but nothing has stopped this message. I can download files and view them on my computer fine. I simply can’t access the in-browser 3D viewer on the Sketchfab page anymore.

Although I’ve experienced this problem, it didn’t persist very long

On my little NUC Intel n5100 (integrated intel graphics), Win 11, Opera browser I’ve not experienced any problems. However on my proper computer I7-13700K Nvidia RTX 2060 driver 531.79 (updated 3 May), Win 11, sketchfab 3d viewer was fine on thursday (18 may), but sunday (21 May) showed the error, I’ve updated the browser, closed all open tabs (normally set to reopen when browser starts) and restarted it and everything seems to work fine now.

It works now for me on Chrome, odd that it just started working. I still can’t get it to work on Edge, which is weird because Edge used to be my primary browser for accessing the 3D viewer.

Since the Forum is going to Read-Only in a couple days, I’ll move this issue over to a help request. Thank you to everyone trying to assist.