Sound not linked to animation


(Edsahergom) #1

Hi again Sketchfab,

When the sound feature was released I was able to reproduce sounds without having an animation on, but now it seems sound just reproduce when animation is playing. Is it possible to make the sound reproduce independently from the animation.

Thanks for your help.


(Rogyrue) #2

I have the same problem wasted lots of time on this its annoying since upgraded to pro and the sound is a law to itself now :frowning:


(Edsahergom) #3

The sound is also being deleted. It is the third time I have to put the sound in again.


(Paul Sketch) #4

Hi,

Thanks for the report, however I cannot reproduce here.

It would help a lot if you could provide reproducable steps and configuration informations so that I can debug ?
(os, browser, model page, steps, kind of sound)

Meanwhile, just in case, some additional details:
1. model without animation can have sound that loop, in the editor it needs the "loop" button of that sound to be activated ("blue")
2. if sound is not used when you quit the page and you don't save, we don't upload them to server so you do "lose" them


(Rogyrue) #5

I understand When you change the animation speed the sound will not work in sync with the animation .

But when you change the animation speed also the Loop option for audio does not work.

My understanding is the loop should work in audio even if the animation speed is changed ?


(Paul Sketch) #6

Do you have sound with "animation speed" that is not 1.0 ?

When "Animation Speed" is not 1.0, we do not try to play sound at all, so having sound in this case would be a bug.


(Mauricesvay) #7

Hi @Rogyrue,

what do you expect the behavior to be?

  1. When the speed of animation is changed, speed of sound changes
  2. or, When the speed of animation is changed, speed of sound doesn't change

(Rogyrue) #8

Hi thanks for the feedback

I understand that if i change the speed of the animation the sound wont work in cinimatic mode are timed options

But in the online user guide it says the Loop sound option will still work on any animation regardless if you changed the speed are not ?


(Edsahergom) #9

The problem for me comes because I am embedding the models using the sketchfab api viewer so the sound is just reproducing when the animation is reproducing. If I watch the model directly from sketchfab it works but no under de api.

Thanks for your help.


(Mauricesvay) #10

@edsahergom can you share a link that shows the issue?


(Gilles38) #11

Hi all,
I have this problem too: if "Animation Speed" is not 1.0, the sound is not played.
Would be nice to have a button to uncouple animation speed and audio playing.
Thanks