Specular has changed recently?


(Gilles38) #1

Hello,
For all my models I have now specularity on some meshes, such as this plane.
I didn’t have this before. Has anything changed recently in the Sketchfab viewer? I changed nothing on my side…
Thank you.



#2

I’m not sure I understand the problem. That seems to be behaving as expected and I don’t think there has been any change related to this recently.

(Also can you be sure to always include a model URL? It makes it much easier for us to quickly take a look)


(Gilles38) #3

Yes sorry James, I’ll try to include a model number right away next time.
Here are 2 images from the same model taken in 2017 and 2018 from the same model (b13938cc693c475e96b7fd0953786982). I may have changed the light directions or limit the rotations in between but I am sure I would have noticed this specularity. And most importantly: this specularity occurs for all my models with this blue mat and some others meshes.
Hope this helps.
2017:

2018:


(Shaderbytes) #4

in your first post I see your roughness is set to 0 , this is mirror like reflections , as I see you are using a scene light from your second post , this reflection you see is exactly correct. Changing the light direction as you mentioned probably brought about the light reflecting directly on the plane.

Simple change the roughness of your plane to reduce the sharpness of the reflections. Nothing changed in this regard on sketchfab, as you mentioned, you changed the light angle, and this caused the reflection to be direct on the plane.


(Gilles38) #5

Hi @shaderbytes, what puzzles me is that this happens for all my models with this blue plane, something like 80-90 models. I am really surprised that I would have missed that issue on all of htem, that’s why I was asking if something has changed recently. But apparently no.
Anyway thank you for your help


(Shaderbytes) #6

that is weird , they did do reprocessing of models some time ago because of the store addition , maybe something did go wrong in that process on your models? Im just guessing here… Maybe you had it set to glossyness 0 , which is completely burred reflections, and the reprocessing simply changed it to roughness 0 ( the two are just opposites of each other ). I have not heard about such a bug before so that is why i say im guessing but 80-90 models and something changed in the same surface in all of them leads me to make a guess like this because something had to have happened…?


(Gilles38) #7

Yep, exactly the feeling I have. This seems to happen only for meshes for which I changed the roughness or glossiness (I don’t remember which one) in the past.
Can you investigate in this ?
Thanks a lot


(Shaderbytes) #8

i dont work for sketchfab so nothing i can do, even the guys who do work there , this is a case of too late cant roll back anyway etc, so no investigation, even if they found such a edge case bug would help your current situation. You will just have to go into each models settings and change the roughness manually.