SSR only works on dark surfaces?


(Shaderbytes) #1

Hey there

So while im busy with a comp entry i tried out the SSR during my WIP. I noticed though that it only displays on my floor if i make the floor a really dark color? Im i doing something wrong or is this a limitation of SSR?

eg:

this works :

but this does not :

the reference image has a light floor :


(Shaderbytes) #2

ok changing the HDRI helped a bit , I also added clear coat to the floor and bumped the reflectivity to max :


#3

Increasing the metalness of the floor might help, albeit it’s not very physically accurate


(Shaderbytes) #4

Thanks James , i will keep that in mind. As mentioned I found the HDRI seems to affect the effect a lot. I added clearcoat to the float now as well as it also has an option to bump the reflection up some more. Anyway since my last post where i got it to work on a medium to light floor , i changed the HDRI in my scene again and it did cause me to have to darken the floor again to get the SSR to show well, at least darkening the floor in that instance was something I wanted to do anyway for the final look and feel , eg: