SSS settings break on re-upload + VR bug


(Yannick Deharo) #1

Hi everyone and Sketchfab team !!

Everything is in the title. When I reupload a mesh with subsurface scattering settings, I have to set everything back again in this section including maps. Is it a well known bug?

MORE : I notice that the rendering of SSS changes in the normal "viewport" and in the VR one. My draptor, for exemple, is luminous in VR...

Have a nice day ! :slight_smile:


Website Change Log
(Mrchlblng) #2

@YannickDeharo your first point is a known issue; reuploads currently will not rebind SSS and displacement channels at all. This will be fixed soon!


(Rémy Bouquet) #3

For your second issue. In VR many post process are disabled and shadows from light attached to the camera are also disabled. Both can have a big effect on the render especially shadows that are required for SSS.
Could you please point me out to a model that exhibits this issue and maybe I can help.


(Yannick Deharo) #4

Hi ! everyone,

@mrchlblng : Okay, thank you !

@nehon, my draptor model is very different in VR mode, but I notice that on my smartphone only ! ^^

COMPARISON


VR Mode :

I believe it's the "Subsurface Scattering" because it affects all the body (Material name : "Skin"). My "Translucency" is constrained by a map on the wings only.


(Yannick Deharo) #5

My SSS settings are wrongs or this is a bug ?


(Rémy Bouquet) #6

Sorry for the late answer, I couldn't reproduce the issue so it might be device specific. We are going to dig into it, we'll keep you updated.


(Stephomi) #7

@YannickDeharo What is your device exactly? (and version of chrome ideally too)

So far we could not reproduce .

Edit: nevermind I can reproduce, we are on it!


(Yannick Deharo) #8

Initially, that was on a Samsung Galaxy S5, but I see that you are on it !
Please keep me updated :wink: !

Have a good day !


#9

I think this should be fixed now


(Yannick Deharo) #10

Very cool ! Thank you for your answer. :slight_smile: