Sketchfab Forum

Static pose, is there a way to skip this pose

(Steebus) #1

Hi guys,

When I play my character animation the silly T-pose is the first thing you see before the animation kicks in, is there any way to prevent this?


(Steebus) #2

Also after splitting an animation in 3dxchange into a list short 'performances' I exported these to animations inside an FBX. 1. Strangely enough the cycle of the animation jumps back to the static pose every time before starting the next animation cycle, making it a jittery experience.
2. Also some of the animations weren't the length they should be, they were much longer, I'm going to run some tests with splitting the animations before 3dxchange, and re-upload the file.



It takes some time to download the animation information, so if the animation is very long, or there are many animations, the static pose will display for some time.

Not sure about the second issue. Can you post a link to the model?

(Steebus) #4

Hi James
Thanks for getting back to me

I've fixed the second issue by separating the motions, the issue occurred the following way:
* imported one 2 minute motion into 3dxchange
* split the motion clip into performances using the time clips with consecutive start and end times.
* it produced the desired result in 3dxchange
* the import in sketchfab produced animations that were e.g. 50 seconds in stead of 15
* it seemed all animations were the length of the longest animation
* I deleted the original upload as I replaced the animations with properly cut iMotionPlus files

Issue 1
- The default T pose has been driving me crazy:), I wish there was a way to avoid it and use a custom animation frame as default pose.(feature request)
I've uploaded one of the results for you (which appears to imported upside down), the static pose is still the T pose.

I tried the fbx export from character creator and not use the universal T pose, it kinda worked to produced a 'baked' animation with a new pose, but now the jacket and underlying shirt were now producing clipping which will require me to investigate settings in CC to influence this. I gave up for now, the 3D team is indicating they should be able to circumvent this working from 3D max, I use Iclone for Prototyping.

  • I probably need to have a separate chat to Reallusion why Character creator has an t-pose option in FBX export but not in the export straight to sketchfab option, I'm sure there is a reason they are aware of:) I do realise none of these models are overly optimised.

File with T-pose, which is producing a jittered result when I use the api to change animations because it jumps to static pose each time