Step by step how to view VR on desktop (Vive)?

vr

(Pederw) #1

Ok so I thought I would check some Vr in HTC vive on Sketchfab.
1. Start by downloading Chromium build, so far so good..
2. Instructions on how to set flags was none on this page


3. Found out on other page (https://webvr.info/get-chrome/) that i have to go to
chrome://flags/#enable-gamepad-extensions in the chrome browser..ok step 2 checked after activating in Chromium.
4. Start SteamVR and goes to my model and click the VR-symbol..?

Nothing happens? I get the split screen on the browser, but on my HTC-vive its just SteamVRs starting point?

How do I get the 3D-vision on the browser to my glasses? Googled a lot but not much info. Guess its obvious for developers that i need to checkmark xxxxxx-box but seems impossible for me to figure out how to get the stereoscopic view to my glasses.

please guide me and update your instructions just a little bit.. :wink: Thanks!


(Waleguene) #2

Hi @pederw,

We tested here with the latest chrome build and it works well.
What's the status of SteamVR when you click on the VR-Symbol ? (givenin the small SteamVR window)
Does the split screen react when you move the headset, is the tracking working ?

Could you give a try with this sample and tell us how it goes?
https://toji.github.io/webvr-samples/03-vr-presentation.html

Also note that pushing the "on/off" button on the controllers triggers Steam's menu (but you can still see the Skfb scene in the background)

Thanks and keep us in touch!


(Protestdesign) #3

Hi @pederw,

Have you been able to figure it out? I have the same the problem and I have been trying to solve it for days. My guess it that for some reason WebVR doesn't detect Vive. I have no clue how to fix that though - like you said there's very little info online on the subject.


(Pederw) #4

The tracking does not work but the controllers work.
Using win 10, EVGA 1080, Asus X99 all drivers are updated. HTC drivers updated.


(Pederw) #5

Same status as before. Not working :disappointed:


(Rich88) #6

I'm having the same problem. Latest chromium build, flags set, webvr example pages WORK including head tracking, but sketchfab "View in VR" doesn't show anything in my Vive. :sob:


(Protestdesign) #7

I finally got it working today after struggling with it for days. I switched computers (no idea why that helped) and installed Chromium v1 Jul 29. The lastest version 1.1 did not work for me at all. With v1 you do not need to enable gamepad extensions -flag, it's not even available. You should not try to install WebVR from the settings/extensions -menu as WebVR is seems to be built in.


(Pederw) #8

Sounds like the VR-icon should have beta-text written all over. But on the other hand I like that Sketchfab pushes it forward otherwise we would not see a fast implementation in the browsers. But I think Better tutorials and continuously following up each web-build from Sketchfabs side would make things better for users. I will try Protestdesigns approach and install an earlier build and see if it helps, thanks for sharing possible solution:heart_eyes: ! appreciate!


(Pederw) #9

Update.
The samples on this page (https://webvr.info/samples/)seems all to work.
But nothing on sketchup pages.
WebVR chromium ver. 1.1


(Bart) #10

I had many troubles setting it up too and ended up using the Chrome build from August 29:

https://drive.google.com/drive/u/0/folders/0BzudLt22BqGRQUExYzVoLU5VT2c


(Stephomi) #11

Should be fixed on the next release, probably today.


(Pederw) #12

Great news!, Have a demo for a client I would like to show as soon as possible. I hold on for some more days then. :wink:


(Stephomi) #13

The last chrome webvr version should work fine on model page now.
However, for now the launcher won't work ("view in vr" yellow button).

If you are adventurous, you can try firefox nightly, they have started webvr but I don't think they have added gamepad yet (at least it didn't work for the oculus remote when I tried).


(Conorg) #14

Great work guys and I'm really looking forward to seeing my models in HTCVive, but at the moment I still can't get it to work :frowning: Followed all of above (Vive all up to date BTW) and tried archive and new builds of chrome. Both the head tracking and controller tracking is working - see movement on desktop split screen ok but nothing being sent to the headset, just see the 'blank' VR grid space SteamVR states 'Chrome unresponsive'. I'm running an A51 PC with 1080 cards so plenty of grunt, just can't get models onto the headset. The Sketchfab Vive gallery works great BTW. Anyway of adding models to that app? I've attached a link to screenshot.

Thanks,

Con.


(Blackorchid) #15

hi using HTC vive

i can see the web browser and it's vr view ports on my monitor but nothing shows up in the headset
as per your instruction i have steam vr running...yet i don't get the browser in the headset other than the blank startup scene from the vive

so this doesn't work and your about flags link is not a webpage either throw up a blank page
how about you make a video and to make it CRYSTAL CLEAR?

frustrated.


(Blackorchid) #16

fixed found the "flags" needed and now working!