Stop Camera Clipping inside model?


(Seanmar) #1

Is there a way to stop the camera from zooming inside of the 3D model in the viewer?


(Cedric) #2

Hi,
It's not possible today to limit the zoom in the viewer. What would you like to do ? limit the zoom to a range from the center of the scene ?
Could you describe more what do you want ?

Cedric


(Seanmar) #3

Hi thanks for the reply,

I would like to stop the camera from zooming into the interior of the model. Currently I can zoom into the middle of the model and see all of the textures which are flipped, which is not ideal for me. I guess you would have to limit the zoom amount to stop this from happening?

Sean


#4

A workaround could be to give everything one-sided rendering. Then, if you go inside the model, it will be invisible.


(Seanmar) #5

Ah yes! that works. It's a good enough solution for me. To be honest I had already selected single sided rendering, but I had the wrong material selected in the drop down. Thanks for your input.


#6

We just launched a Camera Limits feature! I hope it's useful for you.

https://blog.sketchfab.com/introducing-camera-constraints/
https://help.sketchfab.com/hc/en-us/articles/115003399103-Camera-Limits

We also have an option to change the clipping distance:

Cheers,
James