Stop motion scenes only applying one material

(Derek Watts) #1

This scene should have three materials, but only one is visible in 3D settings.
Models are exported as OBJs, but the problem persists with other file types as well. The matching MTL files confirm that meshes are using three distinctly named materials.

An ugly work around is to segregate models and export in another file format. I.e. scenes with only OBJs have only one material, scenes with OBJ + FBX have two materials, scenes with OBJ + FBX + DAE have three materials, etc.
Here’s a version of the scene exported using three distinct formats:

I’m assuming it’s a bug and not functioning as intended.



I think we discussed this through the Help Center. We still need to investigate on our end. There seems to be some issues with material processing when compositing files in a Timeframe animation. @waleguene will probably be the best person to look into this, but Timeframe is not a huge priority for us, it’s mostly an experiment.

(Derek Watts) #4

You’re correct, sorry for seeming passive aggressive. I plugged it here because it occurred to me that making this visible for other users might be helpful in some capacity.
Thanks, guys.

(Nomadking) #5

I’ve encountered this issue myself a few times, and the best workaround I’ve found is to make sure all your OBJ files reference a single MTL file where you list all the materials needed for your scene.

As most 3D applications will save a different MTL file with each OBJ, this typically means opening the OBJ files in a text editor afterwards and changing the mtllib line at the top to all point to same MTL file. Of course, this also means that you need to be wary of your material names across your whole scene as you work to avoid having to correct any naming conflicts manually.

It still doesn’t get the naming of the materials right (they all take the name of the last material with a number afterwards), but the important separation is there to let you manage your textures etc. It’s not ideal but it’s workable!

(Derek Watts) #6

Interesting. Using a variation of this method I’m able to get 2 materials available in the sketchfab scene. However, that’s only if I botch the mtl file and incorrectly list the materials or list an inadequate number of them. Setting up the mtl and references ‘correctly’ yields the same problem as before, where only a single material is visible.

I may be following your instructions improperly, though. You wouldn’t happen to have a very basic, but functioning, .zip I could use as a recipe, would you?

(Nomadking) #7

It might be because both the MTL and OBJ formats are some ‘loosely’ defined that there are a LOT of ways to write a valid file, so your particular editor workflow might be producing something with different results to mine. I have noticed this myself particular when it comes to what’s written in the MTL file.

I’ll try and get a barebones example up this afternoon and hopefully we can figure this out :nerd_face:

(Nomadking) #8

I made a small private test scene and enabled downloads so you can grab a copy of the ZIP exactly as I uploaded it:


EDIT: Since it’s solved, I’ve removed the model upload and added a zip of the scene for tidiness (2.0 KB)

(Derek Watts) #9

Aha, got it! Thank you so much!

So, it looks like the mtl file needs to specify a texture map per material. It doesn’t matter if it’s amb/dif/spec, but if no texture maps are stated (e.g. ‘map_Kd Textures/My_Diffuse.jpg’), a single material is applied to all objects.

It’s worth noting that each material needs to reference a unique texture or the materials are condensed. I assume this is the reason for my original issue. I wasn’t exporting any texture information at all, so all mats were likely combined in a similar fashion.

Thanks again, sir! I really appreciate the help.

  • Derek

(Nomadking) #10

Glad that you got it working Derek! Always good to know exactly what makes some of these arcane things tick :sweat_smile: