Sketchfab Forum

STOP MOTION shows only first file


(Gilles38) #1

Hi all,
I am trying the STOP MOTION for the first time.
I have seen several topic on this but my issue was not listed.
Uploading of the models and timeframe file was OK but only the first file (frame 1) is displayed. In the 3D settings, it is said that there is no animations. Maybe my sketchfab.timeframe file is wrong ?

Any advice from the staff ?
Thank you.
My model ID : 0190b02e79fd445e83df6e8241899974


(Dark Minaz) #2

0.5 sphere.obj
0.5 cube.obj
0.5 cylinder.obj
as it is stated in the https://help.sketchfab.com/hc/en-us/articles/203058018-Animations#timeframe
so you probably have to remove the "short animation for"
and just write
1.0 Skecthfab_00001.obj (btw you gota typo there, maybe that is causing it :slight_smile: )
1.0 Skecthfab_00002.obj

so to sketchfab_0001.obj (unless your obj got the same typo in it :smiley:


(Gilles38) #3

Hello Dark_minaz,

thank you for your reply.
The typo was the same in both filenames and Sketchfab.timeframe.
To avoid any confusion, I have made a new brand export of the animation from Blender with new names, but the problem is the same as it only shows the frame 1 (Model name is last frame).

I don't know if this is important but I am on Mac.
I dragged all the native files from my folder to the Sketchfab browser window (no zipped folder, otherwise there are folder path issues and additional 'invisible' Mac files)
Could it also be a format issue of the text file ? I noticed that removing the .txt extension gives an error message:

Hope this help to solve this issue.
Tell me what you think
Model ID: 2247ef002105452b90074425588c7821


(Mrchlblng) #4

@gilles38 the animation description needs to be in a file named sketchfab.timeframe; yours is currently named Sketchfab.timeframe.txt (uppercase and extra .txt; not sure why the txt extensino does not appear in your snapshot though). It'll work by just renaming the file and adding it in your achive.


(Gilles38) #5

Great
Thank you mrchlblng
For Mac users, you'll need to do a cmd-I and click the arrow in front of "Name and extension" then uncheck "Hide extension" to be able to delete the .txt extension (Yosemite OS).
This is why I didn't see the .txt extension as you mentionned
Thanks again.


(Gilles38) #6

mrchlblng
Can you remove the animation from your reply?
I am not the owner of the character :disappointed:and I am not sure I can show that.
Can ask if you want.


(Mrchlblng) #7

@gilles38 sure, model deleted!