Strange looking normal?

textures

(M G S) #1

Hi everybody, I’m having problems with the way my models looks, and I don’t know what could be the problem…

Please look at these two models:
first
second (I can’t upload more than 2 images, but you can see the problem over the car hood, near the car lights.)

As you can see, there are strange reflections in the metal of both models, I’ve tried to disable the normal map and it seems to solve the problem, but the normal texture looks ok to me, even in substance painter (software I use to bake the highpoly) everything looks fine.

Here you can check the normal map

I hope you can help me with this, because I don’t know how to fix the problem :frowning:

Thank you for taking the time to read all this and for your help!


(Nomadking) #2

Try uploading your normal map as PNG, it looks like errors introduced by JPG image compression.


(M G S) #3

Hello! first, thank you for your answer :slight_smile:
I’ve uploaded the textures in png format (since I used sketchfab profile to upload the model I couldn’t choose png format in substance painter). The problem is still there… as you can see in the picture,

Model link

I don’t know if this is a regular thing, maybe the reflections works that way in the viewer, or its something I did wrong with my model.

Please if you have any idea of what is going wrong here, tell me :slight_smile:
Thank you!


(Nomadking) #4

The normal map does seem a bit ‘muddy’ around the areas where the odd reflections are. What size is the texture you’re uploading? Try something higher. Does it look this way when you assign the normal map in the editor? Or only after saving? (the texture isn’t processed by Sketchfab until you save)

Perhaps @james knows if this the same normal map compression issue talked about in other threads.


(M G S) #5

Yeah texture size was 1024, but now I’ve uploaded a 2048 one (I can’t really use a higher texture for my project, for perfomance issues).
The problems appear in both editor and model viewer, as you can see in the picture. First one is from editor, and the other is from normal model viewer, using 2048 textures.

I’ll upload the normal map so you can check it too, if you dont mind.

Do you think it is a texture problem? I’m using PBR MetalRough profile, with substance painter.
bpr

Thank you again for the help :slight_smile:


(Nomadking) #6

I’m not a Substance user so perhaps another user (@dark_minaz?) knows the best approach to get good Normal maps for use with Sketchfab that I don’t know about. I could be missing some subtle setting.

Since the normal is the only map you have in there I’d be surprised if it was anything else. Even the top flat sections look very choppy and strange (and this doesn’t seem to appear on the map itself);

I’m leaning towards it being a Sketchfab compression issue, but we’d need @james to pop in and confirm it.


(M G S) #7

Ok, yeah the normal is the only map with information, the other textures are just flat color or grayscales, so I asume is a normal problem. Thank you for taking the time to answering this, I hope we can find a solution to this problem!
I’ll wait for an answer while y try different settings. Thanks you!


(Paul Sketch) #8

16 bits per channel normal maps are not supported currently, so very smooth variation on 16bits becomes those bands when converting in 8bits per channel
Some users found workaround to get 8bits normal map from 16 bits using some dithering etc, if you’re interested Normal map compression options


(M G S) #9

Hi, and thank you for your help.
I can export the textures in 8bits, (actually is how I usually export). I’ve changed the 16bits textures to 8, but the problem remains… So unless substance painter is laying to me when it says textures are in 8bits or maybe thats not the problem.

Thank you again :slight_smile:

EDIT:
I’ve also tried the “?image_compression=0” at the end of the link, but it doesn’t seems to work :frowning:


(Stephomi) #10

The biggest problem is that your normalmaps should have the “flipY” option ticked in sketchfab editor, it’ll look much better.

We compress the textures for the embed/viewer (but we always use the original textures in the editor).
So this option only makes sense in the viewer.

As for the 16bit issue, converting it to 8bit won’t change anything because that’s what we are doing on our side. If you do that, the information is lost for good, however you can try to dither it https://polycount.com/discussion/148303/of-bit-depths-banding-and-normal-maps
It looks like that substance designer (not painter though) is doing that automatically when exporting to 8bit https://forum.allegorithmic.com/index.php?topic=22229.0

That being said, when I try your normalmap on substance painter 2 (phong2_normal), I have banding and the normalmap is 8b.
The normalmap that you posted in this thread are 8 bit too (jpg is always 8 bit anyway)


(M G S) #11

Hi again. You are right, I’ve changed the textures from 16 to 8 in photoshop and it looks way better. I don’t know if I can make it look better or thats the way it has to look.
You can check the result here: truck tesla

So, problem solved? What do you think?

Thank you all for the help :slight_smile:


(Stephomi) #12

Yes, much better with flipY on, you should tick flipY for the wheel and other materials too!

In the viewer the normalmap tentds to be ruined by the compression (we convert everything to jpg to reduce download size). Currently, there is nothing you can do to bypass this compression. In most cases, it works fine but on certain normalmaps on glossy surfaces it can cause issues.

As for dithering maybe it’s too strong, it’s possible that the dithering is making the jpg compression worse (not 100% sure about that). Getting the best result in both the viewer and editor can be annoying I admit.


#13

We’ve started implementing a feature to force models to use lossless versions of normal maps. This can only be done on a case-by-case basis for individual models as needed. I just did it on this model and it looks much better.


(M G S) #14

Yep, thank you again! I flipped the normals and everything looks way better now.
I really apreciate the help! I’ll be waiting for that new feature :slight_smile: