Strange normal texture only in model view

Hello dear community, I am new here and hope someone can help me.
I have a strange problem in the model view…

The model only shows artifacts on the blade instead of the normal texture (see annotation 10). When I go into the 3D settings, I see the model completely correct. What is wrong here?

I have deleted and re-uploaded the model several times, always the same problem. I created the Katana in Blender 3.4.1, uploaded it as FBX and also via Sketchfab plugin 1.5.0. Since I see the correct texture in the 3D Settings, I doubt an error in the export. Here in Blender also no modifiers are in play (like mirror or something) and all transformations are definitv applyed.

Could it be that the automatic compession in the model view is too strong that the extremely fine texture only arrives as an artifact?
If so, how can I prevent this?

Or what else could be the problem?

Edit 1:
I was able to fix the problem myself with a new normal texture. I intensified the texture in Photoshop, reloaded it via the manager, and then reduced it to 0.3 in the channel. This seems to work fine.

Edit 2:
After a few minutes it looks funny again, but I give up. The model view renderer seems to be quite bad in some cases or the textures are internally compressed too much. This can’t be due to compatibility with older hardware, because then the time-consuming post-processing would have been a thing of the past. Saves bandwidth…

can you show a pic of what its meant to look like in the 3d editor (or whatever 3d tool you made it in)

This is what i see in 3D Editor Settings (with the first version of my normal map).

In the 3D Settings looks okay for me.

And here the result in the 3D View:

Really strange.

um, i am not sure to be honest, since as you say its working fine in the 3d editor, would you be able to share the file? I could upload and see 1. if i am getting the same result and if i do, 2. see if i can find out what is causing it

I have had a few instances of texture looking fine in 3d editor but not the main viewer in relation to using the opacity texture settings along with emission with textures containing alpha (in particular with alpha gradients in the texture image) , im curious have you any alpha areas in the texture images your using in the opacity setting and emission

1 Like

I could send you the file but I can’t find a way to do that via PM. Is it possible here at all? I don’t want to share the project in general.

Ah my trust level has just been increased so I can send the file. I am really grateful for any tip.

I updated the normal map setting on our end and that appears to have fixed it. :slight_smile:

1 Like

Hello abbayc,

Can you please tell me what you adjusted or did I do something wrong in the settings? I would like to avoid this in the future.

But first thank you, now it fits and looks perfect. :+1:

I have the same problem with my katana set.

I’ve fixed it on that model also.

This particular issue is only resolvable on our end currently. Basically, when you upload your model, we do a little bit of normal map compression to ensure that the model loads quickly and displays well in real-time. Most of the time everything looks just fine after that compression, but occasionally there are issues. When this happens, please feel free to reach out to us and we will set your uploaded normal map to override the compressed version.


All right, now I get it. Thank you very much for the help and the explanations. Next time I will write directly to the support.


1 Like

opsie , only getting to this now (i should have suggested the sketchfab discord re: the project file), but i see you got things sorted though, nice :+1:

Very informative post .You explain everything in details .Thanks for sharing.