Strange Rendering Error on all PBR models

website
viewer
bug-report
textures

(Kryik1023) #1

So, I'm having a really odd rendering error on PBR models, I've tested it with a lot of models, and it only seems to effect the PBR renderer.

Basically, the UVs on all PBR models are broken, unless you move the camera in very close (a mipmapping error, maybe?), the smoothing is also broken on these models


Bug in Scetchfab Viewer
Texture problems on certain zoom level
(Havoc8i8) #2

Same issue across all chromium browsers

Tested on:
windows 7 x64
amd fx 8320
asus m5a97 plus
asus gtx 970 turbo


(Epifire) #3

Had you checked in your browser's console messages to see if you had any errors? I'm looking at the same HL2 truck right now and it all seems fine on my install of Chrome.


(Havoc8i8) #4

I checked and i am getting this error any ideas.


(Havoc8i8) #5

After a fresh install and enabling Override it fails to load


(Havoc8i8) #6

As well as vivaldy


(Havoc8i8) #7

Anyone know how to fix this


(Stephomi) #8

Hmm I can't reproduce.
I suspect a combination of chrome/driver.

Do you have the issue on https://sketchfab.com/models/5abb55ae8a4147e3a258dd8fcd860ed4?material_packing=0&graph_optimizer=0&merge_materials=0 ?

@havoc8i8 I guess you still have the issue on shadeless mode?

@kryik1023 what is your gpu, is it working on firefox too?

Are you on version 57 of chrome (help -> about chrome)?


(Kryik1023) #9

That link shows up correctly with no errors.

The problem persists on other models in shadeless mode

I personally run a GTX 1060, and I'm on version 57 of chrome.


(Havoc8i8) #10

Ok i installed this version Chrome 53.0.2785.89 and it fix the texture and shaders, my guess is that it's a chrome issue but i can't figure out what it is and how to fix it for the new versions


(Havoc8i8) #11

Also i remove all nvidia drivers and installed 378.78 but that did not help


(Stephomi) #12

https://sketchfab.com/models/5abb55ae8a4147e3a258dd8fcd860ed4?material_packing=1&graph_optimizer=1&merge_materials=1

https://sketchfab.com/models/5abb55ae8a4147e3a258dd8fcd860ed4?material_packing=0&graph_optimizer=1&merge_materials=1

https://sketchfab.com/models/5abb55ae8a4147e3a258dd8fcd860ed4?material_packing=1&graph_optimizer=0&merge_materials=1

https://sketchfab.com/models/5abb55ae8a4147e3a258dd8fcd860ed4?material_packing=1&graph_optimizer=1"&merge_materials=0

^ any differences between those links?

It's very probably an issue with chrome, but if I can pinpoint an issue, I can make a better bug report so that it get fixed sooner.

Also ideally, you could test chrome canary to see if it's already been fixed (canary beta/dev tends to fiddle with chrome profile which can be a bothersome though)


(Havoc8i8) #13

links in canary, second one displays properly

In Chrome 53.0.2785.89 all display properly


(Havoc8i8) #14

Also i first encoltard the problem in vivaldi after their last update i don't know if that helps


(Kryik1023) #15

All but the second link are botched-up


(Gatitoscavenger) #16

I have the same issue, but it only happens when the textures has the trilinear filtering, changing them to bilinear or nearest seems to fix the problem.


(Stephomi) #17

Still can't reproduce :cry:.

Vivaldi is using blink rendering engine as well, so not really a surprise it also has the issue.
I made a chrome bug report :
https://bugs.chromium.org/p/chromium/issues/detail?id=709162


(Stephomi) #18

https://bugs.chromium.org/p/chromium/issues/detail?id=709162#c3
^ @kryik1023 @gatitoscavenger @havoc8i8


(Havoc8i8) #19

I installed a win 10 on my machine the issue disappeared,
it still bugs me i wasn't able to find the root problem :person_frowning:


(Kryik1023) #20

I have found a semi-solution, setting your texture filtering to Bilinear instead of Trilinear seems to fix the issue.