Texture Compression in Published View

Hey there!
I’m having an issue where the model’s textures look amazing in the editor view, but in the published view it has some compression issues. Is there anything I can do to fix this? I searched the forums but cannot quite find a straight answer on how to fix this. I’ve added a photo to better show what I’m talking about. It’s happening mostly on the metal part there.
Here’s a link to the model: https://skfb.ly/o7yVI

I just tweaked a normal map setting on our end. Does it look right now?

That didn’t seem to work, unfortunately. :frowning: If there’s anything I can do on my end to fix it then please let me know.

Try once more? (It may take a couple of refreshes.)

I’m seeing this:

I refreshed it a few times and that seemed to work! It looks better now! Thanks so much for your help!

You’re very welcome. :slight_smile: