Texture Display Problems


(Overhead) #1

Hallo everybody,

Im facing a problem with displaing a textures on one of my models. It never heppen until now and i was using the same way of "exporting and importing"
I can see the textures also in Texture manager, i can also apply them on my model... but then it shows just a pure grey color without any texture...the zipped file with textures has just 30MB

Any idea what can be wrong?

Thanks a lot


#2

Hello,

Can you post a link to the model so I can take a closer look?

My first suspicion is that there are more than 100 unique materials in your upload.

See: https://help.sketchfab.com/hc/en-us/articles/202600873-Materials-and-Textures?mobile_site=true#materials


(Overhead) #3

Hi James,

The model is not published yet so i hope you can open it: https://sketchfab.com/models/0003979ab7914d4f926e17b099383344

I used just 3 textures and the biggest one is 8192x8192 pix. I´ve also checked the link you sent but i cant find anything what i could do wrong.
Hopefully you will find where i made a mistake.

Thanks again


#4

Hello,

It looks like the UV maps are not set up correctly. This is from 3ds Max? Have you tried our Exporter plugin or exporting FBX instead of OBJ? https://sketchfab.com/exporters/3dsmax

By the way, we only render "power of 2" textures, so your 5000x2500 and 3000x1500 textures will never be used. They are replaced by 4096x2048 and 2048x1024 versions, respectively.

https://help.sketchfab.com/hc/en-us/articles/202600873-Materials-and-Textures#textures-processing


(Overhead) #5

Hi again,

thanks for your quick advice.
I was trying it also with FBX export but the size of the file increast to 260mb... and thats over limit from PRO acount. Do you think if i will change the resolution of the textures it could help?


#6

We support uploading compressed ZIP/RAR/7z files, which can save a lot of space. You could also leave the textures out and upload them manually in 3D settings after the model is processed.


(Overhead) #7

Great james. With zipped FBX it worked out. Thanks for advices :slight_smile: