Texture doesn't show correctly once uploaded on sketchfab

3dsmax

(Mattsverkest) #1

Hi there :smile:

I'm having issues with my textures when I upload my scene to sketchfab. I use 3dsmax and the app from sketchfab, without lightbaking (when on, it's even more weirder + we aren't allowed to set this on according to the assignment) etc. Once uploaded, everything seems to be normal, all the models are displayed correctly without textures ofcourse. I just need to apply the texture, but then it doesn't show them correctly: they are either stretched or tiled. I presume it's an issue with the unwrap, but in my max file everything is like it should be. Then I tried to upload it via the website via a 7zip file containing my max file and all the textures in jpeg, but I got an error that one of the files is not supported (error 10).

The strange thing is that I can upload any model from the app correctly, but with my scene it's just not working. Any idea what I'm missing here?

Best regards,
Matts Verkest


FBX texture issue
#2

Hi Matts :smile:

I only see one model on your account and it looks ok to me. Could you send me a link to one that's causing trouble?

And indeed, we don't support .max files natively, they need to be exported in another format like FBX or OBJ.

James


(Mattsverkest) #3

Hi James,

First of all thank you for your reply!

Here's a link to my model: https://sketchfab.com/models/24c3d3dcc3b04ca296fb23935c13d5ac
If you look closely to the texture in the middle, it is tiled but very very small. And the other texture I've imported now is stretched.

Best regards,
Matts Verkest


(Klaasnienhuis) #4

Hey Matts, not sure if this applies to you but in general tiling settings stored in the materials in 3dsMax are not exported. Only the tiling you put in actual UV coordinates (unwrap or UVW modifier) are exported. The tiling settings in the materials are quite specific to 3dsMax.
So, check your textures and see if there are tiling and offset settings and set them to 0 for offsets and 1 for tiling. Then solve your tiling in the modifiers.


(Mattsverkest) #5

Hey Klaas, thank you for your input. I'll look into it now.

Edit: the offsets and tiling settings were already on 0 and 1 respectively.


(Scrotty) #6

So I tried asking on the 3Ds Max forums but...they're quite dead. Anyway, when I upload my .fbx it looks as if the Unwrap UVW layer was removed or something as the texture repeats itself all over the model. How do I fix this?


(Waleguene) #7

Hi @scrotty,

Thanks for reporting this. Could you point us on the sketchfab model having this issue so we can take a look?
(Also, do you use tiling factors for your textures in 3dsMax ? We do not support this property for now, so the FBX data is ok but as we don't use it, it can lead to such issues.)

Thanks!


#8

@scrotty I merged these two threads, they seem to be the same issue


(Kun Sin) #9

I'm also having this .fbx issue:

HaunterAnim by Kun-Sin on Sketchfab

Not sure what tiling factors are, I just open the slate material editor add a standard material node then a bitmap node with the texture then connect it to the diffuse slot and apply it to the model. I tried exporting with embed media and also without it in a zip with the texture but it resulted in the same.


(Mattsverkest) #10

@james I have solved the tiling and stretching issue by converting my max file to a 3ds file (I've tried a fbx file too but this sets objects upside down and creates groups of objects) and uploading it via a zipfile. The only problem now is with my buildings: is there any way to put multiple materials on one object?

Edit: I think I have an idea for this: I just need to detach everything that uses the same material.


(Mattsverkest) #11

@james I finally got it working, all my materials are like they should but now only one object in my whole scene has decided to randomly float. Is there anyway to fix this on sketchfab? Or do I need to upload it again and hope the glitch is gone?

Edit: It's actually a bug in the 3ds file.


#12

@mattsverkest Glad you go things working!

Sorry I'm not sure what you mean "randomly float"


(Mattsverkest) #13

It's just not in the position where it should be: it floats in the air instead of standing on the ground. But I found out that's actually a bug in the 3ds file. When I upload it via the plugin in 3dsmax it's allright, but the materials still aren't. So I guess I'll just upload it without the object that's buggy and via a 3ds file.


#14

Hmm ok. If you send the .max file to @waleguene he might be able to help.


(Mattsverkest) #15

Ok, thank you for your help.


(Waleguene) #16

Hi @mattsverkest,

As said @james, don't hesitate to send me your .max file so that I can reproduce the issue and help to solve it :smile:


(Mattsverkest) #17

Ok thank you very much! What is the best way to send it to you?


(Waleguene) #18

You can simply zip and attach it to a private message :smile: (click on my username => Message. You will find the upload icon in the toolbar)


(Mattsverkest) #19

I've tried that but it says I can only load jpg, jpeg, png, gif, blend files. (Sorry guys for keeping you busy with my noob questions haha.)


#20

I just enabled all file types.