Texture is not available in model

Hi !
When I upload a GLB model with Elevation API, no texture is being taken into account (see TEST2 - Download Free 3D model by Xavier Fischer - Elevation API (@xfischer) [303ac67] - Sketchfab)

The model, once downloaded has an albedo texture though.

Is there a problem in my model ? (non pow2 texture, but worked fine before)

Tried with power of 2 textures, and still having the same issue.

Hi @xfischer

We did an important update on our glTF processing pipeline which caused a regression bug on GLB embedded images parsing, so the problem doesn’t come from the model.

A fix is on the way, I’ll notify you when it’s released :slight_smile:
Sorry for the inconvenience

1 Like

That’s great to read ! Thanks and good luck with the fix.

Hi! Any news on the bugfix ? Lots of elevationapi users are asking me when the bug will be fixed. Do you know when it could be fixed and released ?

Thanks

I am a Sketchfab pro user (and a geosciences professor at DePauw University) who uses the DEM Net Elevation API to create Sketchfab 3D models.

In the immediate term, we had a class project for my Map Interpretation class due tomorrow that relied on exporting 3D terrain models from DEM Net Elevation API to Sketchfab. This no longer possible with the texture bug, so students in the class can’t complete the project until this is fixed. I have extended the deadline by a week. Do you think it is possible to have it fixed before then?

On a slightly longer timeframe, I also am using this approach to generate 3-D terrain models for a textbook project. It is a critical component of this project, so it would be great to know what the ETA might be for this critical fix.

Thanks much! Sketchfab is an awesome product/service…keep up the good work!

1 Like

@waleguene were you able to make any progress on this issue?

1 Like

Hi @mswilke

A fix is on the way and should be released tomorrow, I’ll let you know when it’s live :+1:
Sorry for the inconvenience

3 Likes

Awesome! Thanks so much for the quick turnaround!

Hi @xfischer and @mswilke

We just released the fix so it should be good now :+1:
Don’t hesitate to report if you see anything weird regarding GLB and textures

1 Like

Thanks ! Tested and worked perfectly :slight_smile: So good to see textures back again ! @mswilke can you test on your side ?

1 Like

Works like a charm! Thanks so much for addressing it so quickly!

1 Like

@waleguene seems the issue is back again (see freshly imported model here : India - Jammu and Cachemire - Download Free 3D model by Xavier Fischer - Elevation API (@xfischer) [55f453a] - Sketchfab)
May the force be with you

Hi @xfischer,

I don’t see any issue with the model you linked, can you give more details about what is missing/buggy ?

Hi and thanks for the quick response. You are right, it’s ok now.

The issue happened during this workflow :

  1. upload model
  2. stay on the upload page and edit 3D settings
  3. save settings
  4. goto model