Texture not loadable - .Blend with UV mapping

blender
textures
upload
3d

(Tdneren) #1

Hello, I am not able to watch any texture from .blend model. Tried the most of things, and found a forumpost, that wrote about UV-settings - as such I have set the image mapping og my texture to Coordinates > UV and projectio beneath that to Cube
My textures are both -jpg and .png (colorspace: sRGB) - have not gone into Image Sampling in the Blender dropdown yet.
Where to set in?

/br


Textures don't show
#2

Did you pack the textures into the .blend file?

See: https://help.sketchfab.com/hc/en-us/articles/209143886-Blender-Materials#blender-textures


(Tdneren) #3

ok tried that, but not working - I have also checked things like GPU and DirectX as well as tried another PC.
I am using Blender 2.77?
if you can tell what you are using settingswise when uploading from blender? (image format, and maybe give me a screenshot of the right side of the blender Texture-column - like my setttings here: http://imgur.com/tUIuPRr)
I use the API/token upload-method already


(Elbriga) #4

This might sound stupid but did you UV unwrap the model?
Edit: I see the problem here. In "mapping" you have set "global" and "cube" this somewhat projects the texture but doesn't use an actual UV map that sketchfab can use.
You can read more about UVs here: https://www.blender.org/manual/editors/uv_image/uv_editing/unwrapping.html

If you haven't looked into yet, I would also recommand switching to Blender Cycles as it provides better compatibility with Sketchfab and even a dedicated exporter.