Texture not working

textures

(Nurui Gumi) #1

So I uploaded my model without any textures. Then I tried to upload a brushed aluminum texture i found on google images. when i set that material to the texture, it just takes on one color. it makes the material silver but it doesn't have the brushed aluminum texture. i tried this with a random picture of my desktop that was more colorful and the material turned red like the picture file, but did not have any of the detail on the picture. admittedly i don't really know what i'm doing. can you give me something to try? i tried images of a few different sizes from 100X100 all the way to 4k+ and it doesn't seem to make any difference. thanks.


(Mrchlblng) #2

Sounds like you are missing UVs (aka texture coordinates) so we use (0, 0) for all vertices hence the uniform color.


(Nurui Gumi) #3

i see, so is that something i could set up in sketchfap or do i need to do that to the model before i upload it?


(Mrchlblng) #4

We do not currently provide UVs automatically (it's a tough subject) so you'll have to compute those in your edition software.


(Nurui Gumi) #5

ok thanks, ill work on it.