Texture quality degradation from sketchfab webviewer to sketchfab editor viewer


(Trevorwgraphics) #1

So this models https://sketchfab.com/models/ff93162da8e74cc2af056f710e285a13 displays with a fair amount of texture degradation in the web viewer, but when I go to edit the model, the viewer does not show these errors.
It seems the normal map is being removed on some parts of the model and degraded on others.
Sketchfab editor view https://prnt.sc/ji9jxj https://prnt.sc/ji9vtp

Sketchfab normal webviewer https://prnt.sc/ji9ka6 https://prnt.sc/ji9whm
I’m not sure why these are showing up as they don’t appear on the original texture files.
Is there a way to correct this?


#2

This is related to normal map compression. We’re working on a feature to use uncompressed normal maps in cases like this where the compressed version is not good enough.

You can read more about our texture processing pipeline here:

https://help.sketchfab.com/hc/en-us/articles/202600873-Materials-and-Textures#textures-processing


(Trevorwgraphics) #4

Is there a way to correct this? My concern is that users who view the model will assume the texture or my skills as an artist are poor quality and lose any interest in purchasing the model.


(Ivanix88) #5

Something like this happened to me with a diffuse texture some time ago, the compression was very noticeable. A workaround would be to increase the texture size so the artifacts aren’t so big, at least it worked for me back then.


(Trevorwgraphics) #6

Thanks for the tip tried re-uploading at a higher resolution and its still distorted with errors. No change in the quality.


(Trevorwgraphics) #7

I thought I had a solution. I was wrong.

I swicthed the normal map to a bump in the sketchfab editor and saved the changes and viewed the model. It defaulted back to a normal map but looked much cleaner.

I also reuploaded the normal map as a .png instead of a .jpg this also corrected the display issue.

I tried switching the texture in the skecthfab editor from trilinear to nearest mipmap. Which has had the best results so far.

So after viewing these changes in multiple browsers from multiple systems, it fixed the issue for about 10 minutes. Then the texture defaulted back to looking worse than before… I’ve tested this three times now and was able to repeat this bug. I don’t understand why it shows up good for a short period then defaults back to a low quality.

Update, I uploaded a directx normal map and it seems to be working. On the different browsers and devices. without the horrific artifacting. We will see if it defaults back to low quality again but, I’m feeling optimistic.

Update, After about a 15 minute wait no luck. The texturel has defaulted back to very low quality.

So I think the only solution at this point is to break the model up into more uvmaps to increase the texel density.


(Bartek Ulkowski) #8

Hello, I am having similar problems example here.
I am ready to but premium subscription if this problem is easy to solve.

Thanks


#9

We don’t generate multi-resolution textures until after a model is published. Can you publish the model and wait 10-15 minutes for the textures to be generated to see if it helps?