Textures do not appear correctly


(Arteco) #1

Hi,
I upload my model directly from Sktechup, but rendering and texture are not satisfaisant: sort of flashing.
Ex:
https://skfb.ly/EKqA
What is the problem?
Thanks for help.


#2

Hi,

I don't see any flashing geometries that I usually associate with overlapping surfaces in SketchUp. I'm also not sure which textures are missing. Could you please post some screenshots of what you expect vs Sketchfab? Sending me the original file would also be really helpful: support@sketchfab.com

James


(Waleguene) #3

Hi @arteco,

Thanks for your report. The issue seems not to appear at each loading. I took a look at your model and as @james mentionned, there are some overlapping surfaces problem with SketchUp models and that's the cause of your flashings. The textured faces are hidden by the no textured one so it looks like textures are missing. Windows have the same issue.

A quick workaround I can suggest to you is to go through the materials (in the 3D settings), find the one that is assigned to the "useless" geometries and set the transparency to 100. It will make them invisible, fixing your face fighting issue and show your textures.
We are aware of this kind of issues with SketchUp and will make our best to fix it.

Btw, I suggest you to disable the "Preserve component hierarchy" option of the exporter (if not already done), it should improve rendering performances on Sketchfab.

Don't hesitate to ask if you have other question,

Aurélien


#4

As Aurélien said, the quick fix is to make the useless materials 100% transparent.

Looks like "material_6" is the troublesome one:

@waleguene - I think these issues might be related to SketchUp's "export two-sided faces". Maybe it's duplicating surfaces and flipping normals, but it doesn't work on Sketchfab because we make everything two-sided by default. I've tried enabling and disabling this option, but it seems to make no difference. Maybe there's a flag in the COLLADA we should look for?


(Arteco) #5

Many thanks, it looks like really better now!