Textures loading at low res on mobile devices

viewer

(Public Art Uk) #1

Hello, Can you help please. When we look at any of our models on any mobile device the model automatically loads in low res. Is there a way we can force high res to be displayed?

Thanks,

Public-art.uk


#2

You can add the the URL parameter ?pixelBudget=8192 for "SD" or ?pixelBudget=0 "HD" (infinity)

Just be careful, it can hurt performance or crash browsers on weaker mobile devices.


(Public Art Uk) #3

Thanks James for your quick reply, I appreciate it can you give me a example using this link that we want to tweet?

Frederick William Owen Potts VC by public-art.uk on Sketchfab

Many thanks,

PA


#4

https://sketchfab.com/models/ba1f23cc0bd14e0384b6993165b15bdd?utm_campaign=ba1f23cc0bd14e0384b6993165b15bdd&utm_medium=embed&utm_source=oembed&pixelBudget=0

This model has a 16k texture, which is very big. Most mobile devices cannot render a texture that big and will use a smaller one, even if you set the parameter.


(Public Art Uk) #5

Thanks James, I will redcuce the texture file and try again. Thank you for your help.


(Public Art Uk) #6

Hi James, I was wondering if it were possible to amend my account so that the extra code was automatically placed on all my models? I'm working on achieving a "sweet spot" for resolution and texture, I will never be using the low res option.

Thank you,

PA


#7

Hi,

I'm afraid that's not possible at the moment, sorry!


(Public Art Uk) #8

Hi James, How can I get our models on my account to only show in HD. I know you have given me the code to add to the URL, but that's only of any use if we send someone a link. If they get to our account on a mobile all they will see is low res. As you appreciate, when you are creating models using photogrammetary the textures are everything. We have to provide at least 4k textures for our models to be viewed in any way close to our standard.

Please advise the best course of action as we thought sketchfab was the place to display our work If you have the code and ability to show only high res I don't understand why we can't have it as part of the pro sketchfab service.... Please advise asap as we cannot ignore mobile devices and 4G

Kind regards,

PA


#9

Hi,

It's not possible at the moment to force HD by default. The system is in place to prevent crashes and slow performance on mobile :confused:


(Public Art Uk) #10

OK, Can I not alter each models URL on my account so when a viewer goes to my account they see what we want? Ifnot our account is pretty useless to us. Please try and give me a solution.:sunglasses:


(Bart) #11

Hi @public_art_uk,

I get your point, but the truth is that mobile hardware has certain limitations we have to keep in mind. We know how much each different phone can handle, and adjust our 'budget' accordingly to prevent people's phones from crashing (which would make us look bad). Setting the resolution to 'high' by default would lead to such crashes and that's not something we're willing to do, sorry.


(Public Art Uk) #12

Hey bartv, Thanks for getting back, Honestly....we really do understand your problem, pleasing everyone is a nightmare, we are not requesting you change anything that effects your policy, and we understand the technical limitations that you have to work in.

Please try and load this model in any mobile device, using any browser and let me know how you get on: https://sketchfab.com/models/25c0949e3cc54265a463e6f1da451f4d

OK, I understand this model and texture is massive, but I like everyone else I'mlearning, and trial and error to perfect a a workflow is part of a professionals work.
So thanks for the reply, but your "budget" consideration dosen't work. The browser crashes as you see. I will remake this and make it very very small in both wireframe and texture, and it will look great....but not at low res.
It seems to me your system workflow needs small adgustments to make you "THE PLACE T BE FOR 3D!"
We will support you no matter what you do as we very much appreciate and LOVE what your Company does...
It's not perfect yet, just like us....but for God's sake you need to set the bar higher in respect to viewing high res textures.

Please look at our problem and don't come back with "sorry"... you know as well as we that "NOTHING IS IMPOSSIBLE"!

The Future is high resolution content...if you don't get that now you will miss the boat.....I hope not, we want to work with you to get the best available today.


(Bart) #13

Some things are impossible when constrained by hardware.


(Paul Sketch) #14

You have to understand that your model need ~11G of Video RAM, because it totally not optimized.
No mobile has 11gb RAM, not to speak of VRAM.
Even old/basic computers will have problems to render that model.
From inside the browser we cannot know the quantity of RAM nor VRAM available. it's prevented by browser vendors for security reasons.

What you're in need of is better scan software tools that generates better mesh, or use a service for mesh optimisation, like https://www.simplygon.com/3d-scan that does the optimisation part for you and generate a new mesh that you can then check and rework to you need before posting to sketchfab.

Explanation of "totally not optimized":

  • What you see at lower resolution is not "lower texture being bad quality", it's much more the mesh texture coordinate and texturing failures appears more clearly, making seams" and "blurred part" appears ( too small "border" between charted triangles in the textures. ).

  • the 4K texture is for a very small part (hat top, and small piece of ground) ? it's a big problem: GPU need to load all the texture, not matter what's used or not, and inside VRAM, t's not compressed like jpeg or png, but raw RGBA values each pixel 32bits. Even if you use one pixel of that 4K texture, GPU need the whole texture in VRAM.

  • The two texture along the mesh you posted, 4k, and 16k, have a very very very very low texel density, with enormous empty parts, which means it could be optimized to same exact rendering quality but with texture at least multiple times smaller. (the 4K could be along r 512 pixels width and the 16k a 8k.)


(Michaelduva) #15

Hey folks !
is there way to force lower resolution SO i could actually load my fbx and not have it crash mobile browser.
second more importantly
same question but once you hit the VR glasses button.

what would you add, if you can add lower rez parameters, to this model to make it work on an iPhone 6 ?


(Michaelduva) #16

my intention was to put the link. not post the model. So, in the event i could change the link to read lower values i would know exactly how to write it.
sketchfab.com
/models/7d3c89bb00da47f5a1e90da06952e631


(Paul Sketch) #17

the url option max_texture_size is the "force lower resolution"
?max_texture_size=256 prevent loading of texture above 256
You can add the option to the embed and a vr link that you craft yourself (or get from browser once in VR mode)


(Michaelduva) #18

Thanks Paul ! @paul_sketch can i increase the 256 ? until i find a good number (where model looks good) or is that an 8bit reference?

ie. ?max_texture_size=256 vs ?max_texture_size=1000

also, any 3d settings that might help load a model on a mobile phone that is "almost" loading ?


(Paul Sketch) #19
  • Yes, try in that order until you're ok with quality and it doesn't crash 256, 512, 1024, 2048, 4096
  • No, no other 3D settings can help here.

(Michaelduva) #20

thanks @paul_sketch ! Im up to 2048 and it still looks like 512. any chance safari doesnt cooperate with the added address
?max_texture_size=1024