Textures not working

textures

(Tomislavveg) #1

Edit, solved (problem was probably some internet browser glitch).

I created character model with rig and animations. I exported FBX from blender, imported it to sketchfab. Animations work, but when i try to add texture maps, everything is black. Same FBX file works perfectly when i import it to Unity. I can add and see all color, normal and metalnes maps. Only here i cant get textures to work. Where is the problem?


(Waleguene) #3

Hi @tomislavveg,

Everything is black when you are in the model page or in the editor page ? how does the model look in the editor ?

UVs seem to be ok and after some tests on our side, textures load correctly and are visible on the model when we add them. Is there anything specific with the texture ?


(Tomislavveg) #4

Hi, Sorry for taking me longer to reply, i was out... Now everything is ok. Strange... Maybe it was mozila problem yesterday? I should have tried in chrome then. Will do if this happen again in the future.


(Waleguene) #5

Okay, happy to see that it works.

Note that we recently had some "black textures" issues on models due to several reasons (texture optimization etc) that could explain that you had the issue and that it works now.
If it happens again, don't hesitate to keep us in touch and telling us in which context (model page or editor) will help us to debug :slight_smile:

Thanks!