Textures resolutions are significantly reduced

upload
3d
textures

(Grimwolf) #1

The textures on my models seem to be getting significantly reduced. I can’t find any option anywhere to change this (I’ve seen many mentions of an SD/HD switch, but cannot find one), and I’m viewing them on a high-end desktop computer.
The textures are originally 2k.
After importing everything, the model looks extremely muddy. Even the normals are blurred.
I used the export option found directly inside of Substance Painter.
Here’s an image of one of my models from inside Substance Painter, followed by the Sketchfab scene;

Sketchfab


(Shaderbytes) #2

try add some post process sharpening to your scene , i suggest 15 at max , anything above that will have sharpening artifacts


(Grimwolf) #3

The normals are still slightly off, but it’s definitely an improvement.


#4

It looks like an issue with normal map compression. We’re working to improve this.

If you upload a JPG normal map instead of a PNG, it might help because we convert your PNG to a JPG.


(Grimwolf) #5

The Sketchfab export option of Substance Painter automatically uses .JPG


#6

Looks like it uses PNG for normal maps and JPG for others.


(Grimwolf) #7

Oh, it does indeed. Strange. I’ll try that out later.


(Grimwolf) #8

I switched the normal to .JPG, and that seems to have fixed it. It looks fine even without the sharpen filter now.