Thumbnails/previews not displaying the fully loaded textures


(Sflow) #1

Hi, I've uploaded 2 new models today and for both of them the thumbnails/previews don't show the final result. It looks exactly like the textures do initially, before everything is cached properly.

Not sure if relevant, but the other models where uploaded a few months ago and use PBR specular/glossiness, while the new models use PBR metal/roughness.

If you could investigate what is happening here, that would be excellent. Thanks!


(Mauricesvay) #2

Hi @sflow,

thanks for reporting the issue. We have identified the issue and are working on fix for automatic previews. Meanwhile, you can save the thumbnail manually from the editor to fix your thumbnails.


(Sflow) #3

Oh I should have mentioned, I did save the previews manually and yet it shows up like this!


(Mauricesvay) #4

There might be some delay before the updated thumbnail shows up. A fix is on its way.


(Sflow) #5

Looking great now, thanks Maurice!


(Sflow) #6

So, it looks like the problem isn't gone after all. I did fix some texturing issues earlier today and ever since, the thumbnail for this model: https://sketchfab.com/models/500d1a96e58648bb91f5f5519c8471ce stays in its low res textured state.

To make it worse, it's also showing like this when embedded over at artstation(which I have replaced with a custom thumbnail), but also over on itsartmag @ http://www.itsartmag.com/features/sketchfab-turntable-models-selection-28/ where I can't do anything about it.

edit: Ok, so I tried saving the preview from the inside of "3d settings" this kept producing the issue described above.

However, saving the preview from the model view, which I didn't realise you could do, works just great.

So, issue resolved, kind off smile


(Mauricesvay) #7

Sorry for the inconvenience and I'm happy that it worked out in the end.
We've deployed a permanent fix and thumbnails should be back to normal now.