Touch screen support broken in Chrome and Edge


(Landy42) #1

As the topic title suggests, touch screen rotation/panning of Sketchfab models no longer works in google chrome. I am not sure how long this has been happening as I haven’t loaded a model on my touch device (surface pro 3 win10 latest build) for a while, but after a bit of a hunt around, it seems that the onTouch APIs have been disabled by default since Chrome version 70. Edge has the same problem, but it works in firefox.

I know this isn’t a fault of Sketchfab, but any advice on how to rectify the issue would be appreciated. Many websites appear to be affected by this (including earth.nullschool.net), but in others still respond to touch screen (e.g. google maps). Some searching reveals there is a manual fix for it, but there are no clear instructions on how to do it:
https://www.chromestatus.com/feature/4764225348042752

Any suggestions?
cheers
Bill


(Landy42) #2

So I managed to figure this one out, so if anyone else has struck this issue (I’d be surprised if there isn’t), here is what you do to reinstate touch screen controls in Chrome:
In Chrome’s address bar type: chrome://flags
Once there, scroll down to “Touch Events API”. You’ll notice that it set to ‘disabled’. Just change it to ‘enabled’. An option will appear at the bottom of the screen to “relaunch now”. Click that and now touchscreen controls should be restored to rotate models in Sketchfab (and many other websites).

Hope this helps others experiencing this issue.
cheers
Bill


#4

Thanks for posting the solution!


(Landy42) #5

Thanks James - I was just glad I figured it out. Found the answer on a Chrome forum somewhere. I haven’t been able to get touch screen control working in Edge, so if you have an answer to that I’d appreciate it.
cheers
Bill