Sketchfab Forum

Trouble uploading and trouble saving settings

website
upload

(Dwlynch) #1

First,

I'm working in Blender and thankfully the sketchfab exporter works really well. However that is the only way I am able to upload, anytime I try to upload either an .obj or .fbx I get the error message 'unable to save your settings'.

Second,

I've been trying to achieve a very specific effect and with a bit of tinkering on the sketchfab end of things I've been able to get what I'm after. BUT I keep getting this error message

An unexpected error happened while saving the following settings :
Please contact the support team at support@sketchfab.com.

Anyone else have these problems? A work around would be fantastic. I'm working on OSX and have the same exact problems in both Chrome and Safari.


#2

Hmm. You see that error during upload? That should not happen...


(Dwlynch) #3

I see the second error message, the one I quoted, after uploading via the Blender exporter and making changes to the sketchfab settings.


#4

Hmm, can you give me a link to that model?


(Jason Bonham) #5

Same bug for me. Cant upload anything over 1.0 meg. Tried uploading model, then textures only to find out that it will not save after all of the manual work re-making the shaders.

Please make direct FTP or HTTP uploads, Other sites which have this same problem (probably using the same cut and paste code) will allow me to Dropbox HTTP, or FTP upload from my server without any problem. (unity store, Construct 2 store, Turbo squid)

Thanks in advance. This is a really aggravating problem. I have a feeling it has to do with our ISP's because uploading from other sources works on the other sites.

Blender exporter will not even authenticate me anymore. Can only d&d raw models, then the textures. But most of the time cant screenshot or save settings after doing so.

Sorry for the novel size post.


(Dwlynch) #6

This is the model

I tried saving settings just now on my PC and it worked so I guess this may be an OSX bug? I do most of my work on a Mac so any help you could give me on this would be appreciated.

Thanks!


#7

I haven't been able to reproduce this issue on any of our machines/browsers.

Are you able to get the Network response during the error?

For example, in Chrome:

  • Go to View → Developer → Developer tools
  • Go the the Network tab
  • Save Settings
  • When the error message appears, there should be a failed PATCH request in the list
  • Click its name to open more details
  • Go to the Response tab

(Dwlynch) #8

Here is a screenshot of what I'm seeing in the network tab when I try to save changes. Does this help?


#9

That's the Console tab, can you go to the Network tab, and click the name of the failed PATCH request in the list?

It should look something like this (expect with an error message):


(Dwlynch) #10


#11

Hmm, weird.

Can you tell me what settings you tried to change?

Does it work if you don't change anything and just Save?


(Dwlynch) #12

I just tried saving settings after not changing anything on this model
and this model and still got the same error message.

In the past I have tried to change the background, change the materials, and change the shading options. None of those are able to save.


(Dwlynch) #13

I'm also unable to change the names of the models when adjusting properties.


(Jason Bonham) #14

OK i fixed the issue.

It was one of the plugins i use on both Firefox and Chrome.

Fresh install of Chrome, running as another user on this system, and uploaded a 4 meg file without a hiccup. The settings are saving , and the snapshots are working again for me.

Very happy to solve this issue. Now if i can only figure out why it always says it can not authenticate me from the Blender plugin. I put in the code as i was instructed, and the first few uploads worked flawlessly. But now for some reason it is not authenticating me.

I have even tried to get Sketchfab to generate a new key, and the new key did not work either. I recently update blender, i am wondering if the script needs to be reinstalled? Dunno.

I am very happy i can upload the Zip files again. Hope this information helps other people.


#15

Glad you go it working. What plugin was it?

I just uploaded from Blender using your API Token, so I'm not sure what the issue could be on your end :frowning: